Opening 2017 make files with trial version of Pro 2022

Recently I installed the trial version of Pro 2022, with the intention to buy. When I access a file created with Make 2017 in Windows Explorer it is not possible to open this with Pro 2022.
This is what I do:
Rightclick Open with… Windows offers to open with Make 2017. I scroll down the list of other apps, but no Pro 2022 icon is found. Then i choose to locate another app on this computer. I locate: C:\Program Files\SketchUp\SketchUp 2022. I double click SketchUp.exe. Now the file opens but still in the Make 2017 application!!
Is this because I have the trial version?

Probably it’s due to incorrect installation of SketchUp 2022. Find the downloaded installer, right click on it, choose Run as administrator, choose Repair if you are presented with that option. After that open SketchUp 2022 and in File>Open, select the desired file you wish to work on.

Thanks DaveR for trying to help me. I Choosed Repair as Administrator, but to no avail. 2017 version still opens after using the 2022 SktechUp.exe

What happens if you double-click on an SKP file that was created by SketchUp Pro 2022 - which version of SketchUp is launched by Windows to read that file?

Perhaps you misunderstood @DaveR 's last suggestion. Just to be clear, I think his suggestion was to launch SketchUp Pro 2022, and from within the application choose the Open function from SketchUp’s File menu. When the choose-file dialog box appears, select the desired SKP file that had been created with SketchUp 2017 and click OK or Open (whatever the dialog button says). There should be no way that this sequence would cause SketchUp 2017 to suddenly launch and read the chosen file.

The association between file extension (such as SKP) and an application is managed by the operating system. If you want to be able to double-click on any SKP file in a File Explorer window and have SketchUp Pro 2022 launch and read the file, I think you will need to convince Windows to do that via the file extension association.

1 Like

In the Open With menu, how many entries are there for SketchUp 2017?

Double clicking on a file created by the 2022 Pro results in opening by 2017 Make.
Files created by 2022 can be opened only from within 2022 Pro after having launched it from the Start Menu.
Files created by 2017 can also be opened from witin the 2022 application. This warning pops up: This is file version 17.2.2555 and that iI will not be able to read with the old application after saving it in SketchUp 2022.This seems perfectly normal to me.
However when I save this file, in the Save As dialog box I can choose from these file types: SketchUp models (*.skp) (default) and a whole bunch of older file types, 2022 is not among these file types/ When I save with the default file type it will again be saved as a 2017 file. When I open this file again from explorer by double clicking the pop up window says: The file was created in a newer version. You have version 17.2.2555. You need version 22.0.354.
Indeed I need to convince windows somehow to do it in the right way. But how???
I’m thinking about uninstalling 2017, but I must be sure first that I will be able to read, change and save all my old drawings with 2022.

There is only one entry for SketchUp 2017 at the very top, being suggested by Windows.

I’m not at a Windows machine right now so I can’t check where in Windows Settings is the interface for managing the association between file extensions and applications. Perhaps another user will be able to describe the Windows UI to do that.

Any given version of SketchUp can read (and then modify and re-save) SKP files created by that version and all older versions. I believe this has always been true, ever since SketchUp V2.

Starting with (about) SketchUp Pro 2021, SketchUp can read all SKP files - even those created by newer versions (though some information may be lost when reading an SKP file that was created by a newer version).

2022 ist not listed because it is of course the default of version 2022 (not 2017).

seems to work for you.

2 ways to do this

Right click the file and choose open with …. And choose SketchUp2022


Open SketchUp 2022 from the shortcut it makes on your desktop and start menu and choose open file.
Navigate to the file and open it inside SU2022.

SketchUp 2022 can 100% open any previous files you have made.

SketchUp 2022 is not available after right clicking a file and choosing Open with. The problem seems to be that Windows 10 is not picking up the right data for this function. Opening a file from within the SketchUp Pro 2022 application is possible. After creating a new drawing it can be saved as a 2022 file without problem from within the application. Saving an old (2017) drawing after opening it in the SU2022 application as a 2022 drawing is not possible. Windows does not seem to know Sketchup Pro 2022 exists.

What happens when you try? The Save As dialog window in SketchUp offers a list of old SketchUp formats to choose to save the SKP file, and 2017 should be in the list. When you select SketchUp 2017 format from the list and then click OK or Save (whatever the button says), what happens?

I can save it in 2017 format without any problem.

OK, good do know. Sorry, I misinterpreted your prior reply about unable to save as a 2022 format. What happens when you run SketchUp Pro 2022, read in a 2017 SKP file, then try to save the model as a 2022 SKP file?

My problem is solved with help of the Trimble support team. I still had SU Make 2017 active on my machine. After removing it SU Pro 2022 starting acting as expected.
Thanks to all wonderfull people on this forum who have tried to help me out!

1 Like

Still a strange problem, it shouldn’t be a problem to have multiple versions of Sketchup on your computer!