Open downloaded exercise files on Mac

After downloading the exercise file, the files donot open when I click twice to get the dropdown menu were you can select ‘open’. How can I open this on Apple Macbook?

Can you be more specific as to which exercise files you are referring to? There are multiple tracks on Campus that use them. Thanks.
Also, the files are compressed in .zip format. You should be able to ‘unzip’ natively but if not, try using this: https://itunes.apple.com/us/app/the-unarchiver/id425424353?mt=12

I downloaded from this page:
https://learn.sketchup.com/track/sketchup-fundamentals-part-1,

and also from https://learn.sketchup.com/course/move-tool/move-tool

Ok thanks. Please confirm if you have an unarchive application such as the one in the link I provided as you need that to uncompress the files.

Thank you, yes, I suppose that’s the cause. The link brings me to the App Store and app for iPhone /ipad. How to do this for a Macbook?

The App store works for your laptop or Desktop as well. Just make sure you’re logged in or create an account and click ‘get’ then ‘install’.

If you can’t get it working let me know and I’ll see if we can upload some ‘uncompressed’ exercise files…the trade off is you’ll have to download them one at a time.

Not necessary on macOS. macOS has had built-in unarchiving for as long as I can remember. Just double click any .zip archive and it will create a folder right there with the unpacked contents.

When I click “Download” on either of those, they immediately download, unpack into a folder, and the .zip file is automatically trashed. You shouldn’t have to do anything beyond just opening the individual .skp files at this point, nested in their respective folders.

To open the files, do so from within SketchUp Free (Web). Double clicking the .skp files won’t do anything, because you don’t have a SketchUp app. Your SketchUp is web-based, so you’ll have to do it from within a browser. Hope that helps.

2 Likes

Thanks @monospaced for catching that. I didn’t realize @bosvrouw was using SketchUp Free.
If you haven’t found the answer already, see screenshots below. First make sure you’re logged in and then find ‘Trimble Connect’ in the menu (Top Left). Then choose ‘Add model’ then ‘browse’ to open it from your hard drive. Keep in mind that there are some differences between the web version and the desktop version of SketchUp if you’re following along with the SketchUp Campus lessons.


1 Like

Thanks, I did download it but it does not help.
I can see that I need to do it within a browser since I do have the sketch free webversion as monospaced mentioned.

Yesss!!!
Thanks a lot!

Hello there.
Thanks for posting these. I am also having trouble downloading the exercise files from the SketchUp Campus. I download, then unzip and all that is in the folder are document files, not SKP files. I’ve tried to add using the Trimble Connect, but it just takes me to the projects I’ve saved.

I’m using the free web version right now, though I’ll hopefully upgrade soon. I’m on an old 2015 MacBook Pro.

Having used Sketchup in the past, I’m just doing some refreshers, so I’ve been able to follow along, but would love to have the files.

Thanks!

Hmm… that is curious. The fundamentals download .zip file should create a folder that has 12 folders inside of it, one for each course, and each folder has 1 or several .skp files. I just downloaded it now, it’s still working. Try with a different browser, and if still no luck, can you share an image of what the unzipped folder looks like?

Curious, right?!?
I downloaded using Chrome, figuring that would be better than Safari.
Here’s what I get. It just looks like a bunch of document files. I’ve tried navigating through the SketchUp web app, but that doesn’t seem to work either.

Thanks for the screenshot. My guess, (not completely sure) is that you don’t have any version of SketchUp installed on your Mac, and might have the option to hide file types/ extensions on. So you aren’t seeing the .skp and your computer doesn’t identify what kind of file it is.

Have you tried opening this file in the web version of SketchUp that you are using? Do you know how to do this?

Also, I’ll just comment here, since I help create these videos, that doing the fundamentals videos in the web UI has been a looong time on my radar and in various forms of semi-completion for way to long, so thanks for the kick to keep those moving. :).

Thanks for the reply, and sorry for the delay. I had to run out for a bit.
I understand what you are saying about the file types. Maybe that is the problem?

I did try opening it via the Sketchup web app. The only way I could figure out how to do it was to choose INSERT, which then gave me the option of where to open the file from.
Upon doing so, I still could only find Document files in the folders?!?

I’m assuming that I am doing something wrong, and it could for sure have something to do with me using the web app, but I would think that they designed these tutorials to be used with the free version?

Screen Shot 2020-11-10 at 5.21.57 PM|523x500

Sorry, I missed your response. Inserting the file should work, it will bring it in as a component, but it should at least bring in the file. I’m not sure why that isn’t working for you.

If you haven’t tried it yet, I suggest rather than inserting the file, open it. It looks like you are in the modeling window, in the upper left corner, is the ‘hamburger menu’… The 3 bars. Click on that and choose ‘Home’.

From the ‘Home’ screen, choose ‘Open’ and ‘My Computer’, and try opening that same file. If that also doesn’t work… huh, I really don’t know why that isn’t working.