Opacity Anomalies in SU


#1

I have been working on a simple house design as an exercise to learn some things. Along the way I ran across something strange with a partly transparent material. Please see the image below:

I created the glass-block “window” using a material I created based on the standard “Translucent Glass Block Dark”. I lightened the color a bit, then increased opacity slightly (80 -> 85).

As you can see, other instances of the same window are pretty clearly visible through it. But other objects (a door, the lines where walls meet the floor, etc.) are not. Why the inconsistency?

Also, the outer surface of the texture does not seem to be rendered correctly. It appears that I’m seeing the far, inner surface right through the outer surface. If you look at the window component, you can see that the texture is applied to the inner and outer faces, but not to the sides. Yet when you look through the outer face, you seem to see the texture mapped to the side. Hard to explain, but I hope it can be seen in the image.

Also, I’m uploading a little model that demonstrates the problem.

Am I doing something wrong? Or is this a bug?

Please note that I am still using SU Make 2015 (haven’t got around to updating, yet).

thanks!
ToddTransparencyProb.skp (213.6 KB)


#2

There are two problems. First, the faces of the window component are inside-out, that is, the back side of the faces is on the exterior. Start by reversing them. Then you have painted both sides of these faces with your glass-block material. The combination of so many faces increases the opacity to the point that you have to strain to see the door. Paint the back of each face with a fully transparent material and then decrease the opacity of your glass-block a bit and you get this:


#3

Yes I agree totally, that will fix it. @slbaumgartner beat me to it!


#4

Sorry - I don’t agree. @slbaumgartner was right about the faces being reversed. But changing this didn’t fix anything for me. The 2 problems remain.

Paint the back of each face with a fully transparent material and then decrease the opacity of your glass-block a bit

Yes, that would make the door as visible as the window. But that is not what I want. I want the window as (in)visible as the door. Just like real world glass blocks. The material says translucent, which is what I want - not transparent.

If you look at the model, both the left & right side windows are visible through the front windows.

Meanwhile, looking in from the right side across to the left side, no windows will be visible. But looking from the left side across to the right, the right window is visible. Like this:

(One thing to be aware of - the left & right side windows are oriented the same direction, meaning that the inside of the left window is facing outside on the right window, because I didn’t bother spinning it around. You can see this when you look at the component axes. I think this is influencing the result somehow.)

When I edit the window component on the left, I see this:

The far component seems to take precedence in the rendering over the near component.

To me, this is very odd behavior…

If you open the model in SU 2017 (or 2016), do you see the same results? Or has something been fixed already?


#5

I thought from your question you wanted to make the door more visible, that’s why I agreed with Steve. I will have another look in that case…


#6

Ok yes, I get the same thing.
Not sure if this is acceptable but I can block the view for you.

I now have this:

No changes to material were made. Make sure the faces are orientated correctly and only paint the outer faces,(within the component.) Then draw a rectangle (within the component) as shown below, in the centre. This blocks the light completely.

Like this:

Not sure If it is still right, let me know.

Added later: I’ve tried a few other things without success, the only other option may be to use another material, rather than the rectangle method.

Thanks


#7

Thanks, @Thorleyian, sounds like you’re confirming that this is odd behavior & possibly a bug.

What you propose is a kluge that might work to avoid some visual anomalies, but it does not allow diffuse light into the room, as translucent windows should…

Hopefully, a SketchUp Team Member can check into this and explain what’s going on.


#8

It is a rough and ready solution, I think the material/texture seems to be the problem.
can’t help you any more really

Good luck.


#9

Hello. I actually produced a video walk-through but seeing as Steve and others answered before my upload, I erased my reply. Now, seeing as you’re still having trouble, here’s the video. As always, sorry for the crappy quality. This 3MB video limit is ridiculous when you try to show others help.


#10

Forgot to write. When using transparent materials, try to go by 25 percent increments. For example, 25% transparency for standard glass material is enough to produce the necessary result. In your case, since those are supposed to be slightly thicker glasses, 50 or 75% would do the job.

As you will notice, I first fixed your faces, then applied materials to both the front and back faces. Then reduced the transparency and lastly, most importantly changed the Transparency Quality from the Styles tab which fixed the bug-like view. That’s normal behaviour for the low quality transparency.

You might notice some Z-Fighting while orbiting in the side parts. That’s supposed to be normal because you’re working with a transparency material. If you want to avoid that, you can apply the material only to the big surfaces.

Hint 1: Never apply a texture/material to a whole group. Always go in until you reach the surfaces and apply to them, so as to avoid unnecessary mess later.
Hint 2: That glass material isn’t the best example. Visit the famous SketchUp Textures for free materials. (Requires registration.)


#11

Hi, @VahePogossian, that worked! I wasn’t aware of that transparency setting.

I’m pretty sure that’s what I did, as the texture was not applied to the sides of the component, only to the two main faces.

The texture I used was based on a standard material shipped with SketchUp. But I may check out your link.

Thanks, again!


#12

You’re welcome. :slight_smile:

• Fun Fact • Did you know that the 2017 version of SketchUp renewed this transparency quality feature and there’re only “Faster” and “Nicer” remaining now. If you’d like to find out more, check out What’s New in SketchUp 2017 on their official YouTube channel.


#13

Nice job, I weren’t aware of that setting either. Thought I could be missing something, just couldn’t lay my finger on it.
Will know next time (testimony to the forum again). That material is pretty “foul”, better ones could be found I’m sure!