Need help with rendering transparent materials

materials
transparency

#1

Hi there! I have a question about rendering transparent materials against a transparent background.

In SU2016, when I rendered a transparent material against a transparent background in PNG, I would be able to layer the result in Photoshop and see the underlying layers through the glass.

In SU2017, rendering transparent materials against the background (set to transparent in render options) results in an opaque layer behind the glass. Nothing is visible through it in Photoshop when it’s exported in PNG. Exporting it in TIF is no better - the Alpha channel is solid white instead of grey like I’d expect.

Is there something I’m missing, or is this intended? I unfortunately overwrote all my SU2016 files before I realized this issue so I can’t revert. Searching through Google didn’t yield any satisfactory answers.

Thanks for the help in advance!


#2

There were some changes that would improve transparancy in version 2017. It usually comes down to install the latest drivers for your graphics cards. I am no specialist on this graphic issue, but I can say that you could save your files in a lower version of SketchUp ( file> save as, and then choose the version of your liking)


#3

Oh, facepalms well, I hadn’t known you could save files to an older format. (thanks Su2017 warning) Well, it’s not ideal but it’ll do.

The drivers don’t seem to be the issue. I’ve got the latest installed.

Thanks for the reply!


#4

You can easily see the difference between the exports from SU2017 and SU2016. I used the same model for both of these. The first is SU2017 and the second is SU2016.


I have a vague recollection of this issue being raised before but I don’t recall there being a fix, yet.


#5

I haven’t got a suitable test file at hand so I am just wondering if the “Nicer” Transparency Quality setting (in Styles tray>Edit>Face settings) would help, as it did with many transparent PNG-related problems in the older versions.

Anssi


#6

Good thought, sir. I just tested it. Alas, no luck. The transparent blue area is still opaque in the PNG export.


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.