More material opacity problems

materials

#1

Hi, I’m working on a model building complex and I wanted to try out some different window glazing. I created a gold-tone glass material like this:

To try it out, I did a quick & dirty application to the whole building at once. (This changed not only the exterior windows, but the interior floors as well, which is OK for the moment). Surprisingly, the result with 99% opacity gives inconsistent results - some places look 100% opaque, while other places look maybe 50% opaque. See this image:

I tried changing the transparency quality to ‘Nicer’ in Styles->Edit->Face settings, which reduced the number of places where the problem occurs, but did not eliminate it.

I am currently working in SU Make 2015 (haven’t had a chance to update to 2017, yet). Can someone try a quick test of recreating a similar material in SU 2017 and see if it resolves the problem? (Let me know if you want me to send my model, and I can send it via PM.)

thanks!


#2

This should work fine in make 15. Could be reversed faces, bad grafix card driver, improperly applied textures, or a style issue. Post a link to your model or send me a PM and I’ll take a look.


#3

Hi endlessfix,
here’s the model…

Todd

Hope Plaza.skp (2.67 MB)


#4

This is what I see:

What happens if you remove the material from the top level component and apply it to the faces?

You do have reversed faces on the ground that should be fixed.


#5

Hi Dave,
sorry - didn’t realize endlessfix was your alias.

What happens if you remove the material from the top level component and
apply it to the faces?

Just tried it. That works fine if “transparency quality” is “Nicer”, but
not so well at “Faster” or “Medium”. Just takes longer for a quick try of
a window glazing.

I wish the SU crew would give a pop-up message when someone “paints” a
group or component to warn about this problem and suggest painting
individual faces (as has been recommended in the forum). The pop-up could
also have a check-box for “Don’t show this message again.”

You do have reversed faces on the ground that should be fixed.

Not sure which faces you’re seeing, unless it’s on the very bottom. Are
you using some tool to find reversed faces?

thanks, Todd

(Kinda nice to be able to spend some spare time in SU when it’s so cold out
in MN for 6 months of the year!)


#6

View > Monochrome
will reveal reversed faces, IF the back-face material is distinctively colored, when compared to the front-face…
[Re]Set this in your Style…


#7

It’s not my alias. I was just looking at your file since you posted it and I was curious.

That would imply a graphics card/driver issue.

There are some cases where it is appropriate to paint group or component containers instead of faces but yes, a warning might be nice. On the other hand, I can think of a number of other things for which warnings could be nice. At some point I expect it’s a matter of people having to learn to not touch the hot stove.

The blue faces on the base are reversed. No special tool required to find them. Turn off the materials and set the face style to Monochrome.It’s best to not apply materials until you have face orientation correct.

True that.


#8

Will the real endless fix please stand up… Sorry that’s me and I got caught up in a deadline this morning. Glad DaveR came by to pick up my slack! I looked a the file in pro 16, 17, and 18.

I can recreate the anomalies you are seeing in all three, and they are effected by the transparency quality setting. Interestingly transparency set at “nicer” eliminates them in 18 but not completely in 16. Looks like a quirk of how the transparent rendering works with your asymmetrical building that the anomaly shows up in those specific areas. I built a few square versions of this building as a test and they render cleanly with the same material. Then I bent the buildings with fredotools and the samE building starts to show weirdness once it’s warped. Looks much worse at opacities above %50. I’m still playing with it but I don’t have a total fix for you.


#9

OK, I guess I was just confused there for a bit… I thought I had sent my
model to Riley via PM, but I guess I actually sent it to the whole forum.
So when Dave responded, I thought the only way that was possible was if
Dave was actually Riley.

Anyway…

I’m still playing with it but I don’t have a total fix for you.

No problem, I have the work-around. But it would be good if the developers
took another look at the opacity/transparency handling, because this isn’t
the first time I’ve had issues with it, and I expect a lot of other people
probably have as well, though they may not always post about it here.

Thanks, guys.
Todd


#10

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.