Only one font available in Sketchup Free

Hi, for some reason the past few days I can now only access one font for 3D text in the drop down box.
I used to be able to choose from a variety of fonts.


This is what I’m seeing:
Can you share at least a screenshot?

Your profile says you are using SketchUp 2021 Pro. Are you no longer using it?

I need to upgrade my profile. I am using Sketchup Free.

Please do.

And show us what you are seeing when you try to change the font for text.

Sorry, I can’t figure out how to upload the screenshot.

Drag and drop the image into a reply. Or click on the Upload button.
Screenshot - 9_3_2023 , 11_53_34 AM

One Font
Ohh… That was easy.

You didn’t indicate 3D earlier. I just checked that in SketchUp Go and see this.
Screenshot - 9_3_2023 , 12_04_25 PM

I wonder if it’s a limitation of SketchUp Free. Maybe @colin can chime in.

As you can tell I am barely past the novice stage. I have been using Sketchup Free on a few small projects for the past 6 months or so and have always had access to a few fonts in the drop down. Mysteriously it stopped working a week or so ago and I can only use Open Sans as an option.


Image Font1 is the only font I can use now.
Image Font2 is what I did a couple of weeks ago.

As I wrote, it may be a limitation of the free version now. They make changes from time to time. We’ll have to wait and see if Colin has any input.

I presume this is a hobby thing for you since you are using SketchUp Free. Assuming these places actually exist, maybe you could go and photograph their signs and import those as images in SketchUp.

Is it Shell Lake, Wisconsin? I didn’t know they had a curling club.

I live in Saskatchewan, Canada. It’s actually more than a hobby but I am just an amateur helping my community out. These are designs that are being built here in Shell Lake right now.


Well, let’s see what comes after the long weekend.

Thanks for your help Dave.

1 Like

Are you using the app from the same device as before? 3D Text doesn’t support all fonts available in your computer. I seem to remember that it only works with TTF (TrueType) fonts and not the newer OTF ones. I might be behind times in this.

3D Text, Screen, Label, and Dimension text in SketchUp for Web only use a few web-safe fonts, not the system fonts at all.

I tried in Chrome, Edge, and Firefox, and in all cases I see the five fonts Dave sees. I did find web sites that talked about other tools only showing Open Sans as well, so I’m guessing there is a Windows related issue that can happen.

Possibly Windows 11? I’m using 10.

I have been using the Brave Browser with Windows 11. I will try with another Browser.

I just tried it in Edge and I have the same issue. I have tried on two computers at different locations and still have the problem.