3D Text / Font dialog not working


#1

I’ve been using SketchUp for a years now on a daily basis, and suddenly I can no longer create 3D type using the font/size/style of my choice. It seems like the font dialog box is no longer working, with no choices available. It defaults to the system font, as shown in the images here.

I’ve reinstalled SketchUp, tossed the preferences, checked FontBook and other apps. It seems like this is an issue only with SketchUp since the Font dialog works in all other apps where it is accessed.

Please help. Thank you!


#2

That’s not the 3D Font panel. Ours doesn’t have the controls on top for strikethrough, color, etc… ours looks like (below). We just pull from your system fonts. Where did your screen shot come from?


#3

My screenshot came directly from SketchUp. Those options you say aren’t in
there are just a toolbar you can customize.


#4

Exactly how did you add them in SketchUp. And your font page title says Fonts (and looks like my TextEdit panel, without the fonts). Mine says Fonts (3D Text) in the title, which is why I think yours isn’t from SketchUp.


#5

Hi Barry. I don’t know how I added them, I didn’t manually do anything. This is a fresh install of SketchUp without any customization. When I use the 3D text tool, and click Fonts, this is the dialog that pops up, and it doesn’t function.

If you have a suggestion, please let me know, but I assure you 100% this is not from a different app, no matter how much you insist it is. Thanks,
Ben


#6

Here’s a screenshot directly from SketchUp Pro 2015 showing the dialog, just like you did. Hope this helps?

My workaround was to import type from Illustrator and manually make a shape out of it, but that was quite tedious. Let me know if this is a known bug, and/or if there is a fix. Thanks!


#7

I see the same things Barry sees. Even if you were accidentally showing the TextEdit Fonts window, it’s odd that the size list has a scroller but no list of sizes.

To rule out the 3D part of the problem, what do you get if you choose the Select tool and then select Window/Show Fonts?

It could be a change in the 2016 or 2017 version, which is what we’re using.


#8

Are you trying to use SketchUp 2015 on a new, unsupported operating system version?


#9

Ah, 2015 is the operative item. I get the same thing on Sierra / macOS 10.12. SketchUp 2015 was released in November of 2014, and Sierra was released September 20, 2016. There’s probably code changes in macOS that broke the font panel. I opened 2016 and it worked, so subsequent versions are fine.


#10

When I select “Show Fonts” from the “Window” menu, it brings up the same blank Fonts window.

I’m on SketchUp 2015, and we don’t currently have a budget to upgrade to 2017. My operating system is macOS Sierra, an upgrade dictated by the IT department.

Are you all saying that SketchUp Pro 2015 is not compatible with the official (non-beta) macOS?


#11

I’m using it on the current up-to-date macOS. I was not aware it was unsupported, and I don’t believe it should be unsupported either.


#12

I’m saying that you can’t take any old software program and expect it to work perfectly on OS’s 2 years in the future. It should work, but there might be issues. I worked at NeXT and Apple, this stuff happens.


#13

And it’s happened before. As I noted at the end of this thread, " it’s a bit hard to go back to all previous versions and fix things that Apple or Microsoft will break in the future"


#14

I do believe I should be able to rely on software to work for a couple of years, especially at the Pro level and price, but I am a reasonable person and I understand that this is a glitch that could be addressed, but has not.

Yes, there are issues, and yes, “this stuff happens.” That’s why I’m reporting the issue in hopes of finding a fix, or getting the right people aware of it so that it can be fixed in the future.

The link you shared regarding Outliner doesn’t seem relevant though. Is there a particular section in there that would help this issue?


#15

You should rely on it working forever. On OS’s that it was built for.

If I have SketchUp 2017, and next year the Steam-Powered Babbage Engine Phone OS is released, should I expect SketchUp 2017 to run on the Steam-Powered Babbage Engine Phone OS? No. If Apple gloms on features of the Steam-Powered Babbage Engine Phone OS to Sierra Nevada Torpedo OS 10.14, should I expect it to run? No. You’re asking for software clairvoyance. Chances are it should work, and it mostly does, but there are things like this that pop up.

The Outliner fix was just an example. Sometimes we can find workarounds. Sometimes we can’t. I see nothing obvious here that would allow the font panel to load fonts on Sierra. The Outliner workaround in fact disabled the Outliner, but allowed users to use SketchUp without crashing. You should be happy it’s not crashing.


#16

I’m not sure why you are so aggressively antagonistic about this, but you seem to have missed my point entirely, with all due respect.

I’m simply reporting an issue to software that isn’t that old, in hopes of it being addressed. Repeating over and over that I can’t expect my software issues to be addressed because I’m not buying it each year doesn’t help, I’m sorry. Of course I don’t expect “clairvoyance” in my software, but I do expect perhaps that my issue would be heard and perhaps considered seriously.

I thought posting here would be a way to bring the issue up to the right people, but I may have been awfully mistaken. Sorry for wasting your time.


#17

You’re asking us to update SketchUp 2015, is that correct?


#18

No, I am simply reporting a software issue me and my team are experiencing, as I thought this was the proper way to do such a thing. Yes, as I’ve mentioned several times, this is SketchUp 2015. Our whole team is using it.

I’m not demanding a fix; I’m not asking anyone for an update. I’m reporting an issue in hopes that there might be a resolution. I’ve never done this before, and I created this account for this purpose. This is my first day on this forum and my first issue report.

It seems like you’re saying, in more words than less — and in a roundabout way — that you represent the SketchUp team and this customer should be ashamed to even post here. Thanks.


#19

Answer. Upgrade to 2016, it’s cheap.

Alternative best workaround I can come up with:
you can stop and restart SketchUp with 3D Text tool default values. To do so, open Terminal, and see what your defaults are:

defaults read com.sketchup.SketchUp.2015 | grep -A 9 ThreeDText

It should spew something out like
ThreeDText = {
Align = 0;
Bold = 1;
Extruded = 1;
Extrusion = 3;
FaceName = “Times New Roman”;
Filled = 1;
Height = 10;
Italic = 1;
};

To change the font face to something less aggressively antagonistic than “Times New Roman”, in terminal, do this:

defaults write com.sketchup.SketchUp.2015 ThreeDText -dict-add FaceName “Geneva”

Now Sierra caches core foundation preferences with a daemon, so you must kill the daemon, which will autostart but clears the cache. Do that by typing this in terminal:

killall cfprefsd

Now start SketchUp, and see what the default text is in the 3D Text tool. When you’re done with that and realize your love was really meant for “Times New Roman”, you can quit SketchUp 2015, go back to terminal and switch back to

defaults write com.sketchup.SketchUp.2015 ThreeDText -dict-add FaceName “Times New Roman”

again, killall cfprefsd, and relaunch SketchUp, and your font should be back to “Times New Roman”.

The other text (Screen Text, Leader Text) is drawn from the template, so if you want different text there, you’ll need to have a template with that font specified in it. You can also do it with your template and a hex editor, but that’s a bit trickier.


#20

You read waaaay to much into things. Speaking only for myself: life, edge modelers and forum threads go better for me when I take things at face value.