Ongoing Mac Issue of Crashing. Constant: SU, Nearmap and VRay

This is the crash report I get daily. I have for a long time. But i think this report only goes to Apple. This is the short version of it.

Translated Report (Full Report Below)

Process: SketchUp [63008]
Path: /Applications/SketchUp 2022/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2022
Version: 22.0 (22.0.353)
Code Type: X86-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2022-09-12 12:27:26.6383 -0700
OS Version: macOS 12.5.1 (21G83)
Report Version: 12
Bridge OS Version: 6.6 (19P6066)
Anonymous UUID: 3A9D8739-2DDC-86CC-BF27-6760D8AEDF6F

Sleep/Wake UUID: 7E70C00F-0D09-4346-B937-56D9F007F760

Time Awake Since Boot: 920000 seconds
Time Since Wake: 591 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGABRT)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000388
Exception Codes: 0x0000000000000001, 0x0000000000000388
Exception Note: EXC_CORPSE_NOTIFY

VM Region Info: 0x388 is not in any region. Bytes before following region: 140737487367288
REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
UNUSED SPACE AT START
—>
VM_ALLOCATE 7ffffff0f000-7ffffff10000 [ 4K] r-x/r-x SM=ALI

ID Vend/Dev
bac4 67ef1002
Seconds Ago ID Type
1100000.0 bac4 Attach

Application Specific Information:
abort() called

Thread 0 Crashed:: CrBrowserMain Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x7ff80d00100e __pthread_kill + 10
1 libsystem_pthread.dylib 0x7ff80d0371ff pthread_kill + 263
2 libsystem_c.dylib 0x7ff80cf82d24 abort + 123
3 Ruby 0x10c069e39 die + 9
4 Ruby 0x10c06a063 rb_bug_for_fatal_signal + 547
5 Ruby 0x10c1923fb sigsegv + 91
6 libsystem_platform.dylib 0x7ff80d04cdfd _sigtramp + 29
7 ??? 0x0 ???
8 SketchUp 0x10a5abdd3 CComponentTool::Commit(CSketchUpModel*) + 157
9 SketchUp 0x10a266954 CToolManager::OnLButtonUp(unsigned int, sketchup::CPoint, ISketchView*) + 112
10 SketchUp 0x109ec0b34 0x109ea3000 + 121652
11 AppKit 0x7ff80fd2d2e8 forwardMethod + 204
12 AppKit 0x7ff80fca7df8 -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 2704
13 AppKit 0x7ff80fca714e -[NSWindow(NSEventRouting) sendEvent:] + 352
14 SketchUp 0x109ee622e 0x109ea3000 + 274990
15 AppKit 0x7ff80fca5524 -[NSApplication(NSEvent) sendEvent:] + 352
16 libCommonWebEngine.dylib 0x10b0604c6 -[CefNSApplication sendEvent:] + 117
17 SketchUp 0x109f03cf8 0x109ea3000 + 396536
18 AppKit 0x7ff80ff5e18b -[NSApplication _handleEvent:] + 65
19 AppKit 0x7ff80fb26d3e -[NSApplication run] + 623
20 AppKit 0x7ff80fafac97 NSApplicationMain + 817
21 SketchUp 0x109eb042b main + 144
22 dyld

A bug report was ceayed this tie under: Crash #62770

Have you tried restarting the PC?

It’s a Mac but yes. It solves some things some of the times.

1 Like

I have been running into the same issue forever. We’re an architecture firm and had a Mac mini M1 constantly crashing. I thought it was reaching the max memory bandwidth and with other apps open simultaneously (AutoCAD, email, calendar, safari, etc), things hit a limit and SketchUp would just quit.

So we bought a Mac Studio with an M1 Max and 32gb ram (which has 4x the memory bandwidth of the mini). Still crashing.

If I open the same model on my iMac Pro (2017 intel-based with 64gb ram), I can have the same model open for days without quitting, and never see any crashes.

Seems like SketchUp has not been perfectly optimized for Apple Silicon, and while it did run OK using Rosetta, and still sometimes OK in SU22 which SHOULD be optimized for Apple Silicon, the developers have not yet tested against these DAILY crashes.

If anyone at Trimble/SketchUp monitors these forums, please escalate this to the very top. Your app is absolutely debilitating on modern Macs which are supposed to handle your application so much better than my 5+ year old intel Mac. What’s going on?!

Crash log attached

Sketchup Crash Log.pdf (93.0 KB)

1 Like

Ventura. Your crash logs are running Ventura (mac os 13)
Sketchup 2022 is (still) not listed as compatible with Ventura. They tried it on their macs, it worked, but no stamp of approval.
There are a handful of similar threads on this forum, and the main solution is to rollback to monterrey.

Sketchup is fully optimized with Apple Silicon, it was actually rewritten specially for Silicon. The issue at hand is the difference of rhythm, Mac os beign released in oct/nov while sketchup tends to be released in jan/feb.

Although you’ll find a handful of similar cases here, you’ll also find that many people have made the update without any trouble, including sketchup staff. So it’s not completely clear what is making SU22 crash on some M1/M2 macs.

it’s no secret that the sketchup is poorly optimized for M1/M2 processors

Sketchup 2022 is (still) not listed as compatible with Ventura.

Is that because of the GTK3 compatibility? Inkscape’s website mentioned this with Ventura.

1 Like

… I don’t see what the gimp toolkit has to do in this… :slight_smile:

No, I’d say it is because the dev teams are focused on SU23 and don’t want to spend time answering helpdesk tickets and fixing issues with a version about to be replaced.

If Trimble officially announced that SU22 is compatible with Ventura, they would have to provide fixes to the handful of situation that makes it crash.
Or they can simply NOT endorse Ventura for 22 and answer “well yeah, try it at your own risk”.

edit : I spent 3 years sharing a flat with a dev, and yeah, they’ll do that. no need to divert ressources to fix an issue in an old version if you’re about to release a new - and fixed - one
unless you have a massive team of devs of course, like adobe, releasing fixes and updates every week or so :slight_smile:

1 Like

Yeah but the crashing on the M1 mini started on Monterey too, so it’s got nothing to do with SU22 and Ventura. In fact I was eager to update to Ventura to see if that would solve the issue, but it didn’t.

And SU22 works BEAUTIFULLY on Ventura on my iMac Pro, never ever crashes.

I don’t think SU was re-written for Apple Silicon. Without doing a thing, SU would be emulated via Rosetta 2 on the fly on Apple Silicon. Starting with SU22, Trimble added the Apple Silicon build target and might have needed to add or adapt some code, but it definitely was not re-written for M1/M2.

So while it may run OK, it does not feel fully optimized and the crash logs indicate memory handling errors. I do hope they spent a decent amount of time running M1 and M2 computers with SU22 over the past many months and have addressed these issues in SU23.

I get the annual release cycle, but SU is debilitating on M1/M2. SU22 should have received some intermediate update to remedy in the meantime.

Silence from Trimble on the matter is not encouraging. They could ease the pain by announcing a product roadmap or at least acknowledge the issue has been addressed for a future version/update.

4 Likes

fully agree with you, mate
it’s beyond our strength to wait

How did you verify this, or are you just ranting about something?