Old file won't open

I have an older Sketchup file 2017 i think, that I need and it won’t open, it gives me a message stating that “this doesn’t appear to be a sketchup file” How can I get this to open again?



Upload the file here. Maybe @colin can recover it for you.

What version of SketchUp are you using now? Complete your profile.

ARaymond HQ 2-story exploded bid version 061118.skp (13.4 MB)

righteous, thanks!

just updated to 21.??.?? this afternoon, thought that might be the issue so I made certain I have the latest pro version available

It’s not a SKP file !? [no ‘header-code’…]
Any ideas about what other file-type it might be ??

I was going to try to tell the file to “save as” and resave it as .skp but I don’t know it it would actually convert back to sketchup
or if theres a file converter that can take a TIFF for example and turn it into a skp file?

are these options or just wishful thinking?

There’s nothing to convert a file into a SKP… as far as I know…

rats… its a cool model

You can’t just rename a file to .skp and expect it to open in SketchUp. Assuming you have the original .tiff file, you could import it into SketchUp as an image. It’ll still be an image but you could use it as a reference to create a 3D model from.

Great. So please edit your profile to include that info. Thanks.

I tried to rename it to a few graphic file extensions, but nothing seems to work… not sure what kind of file you have here, but it is not a skp or image files that I can see…

Experienced this exact same issue today. Last opened a viable SU Make 2017 file in Make 2017 and get the same error message at the top of this thread. Can’t figure it out as this is the most recent model I’ve made and accessed it just over a week ago. Every other SU model I open opens fine, without the error. Any clues guys? :flushed: