Offset tool, manual move vs. specified number [solved]

Mac OS X, 10.12.5, SketchUp 17.2.2554

In going through the SketchUp tutorials, I’ve come across a problem.

See: Third introductory video at about 7:00 minutes.

You’re directed to create a window mullion of 1/2". If you use the Offset tool with a mouse controlling how much offset, it works properly. If, however, you type 1/2" into the measurement box, the mullion extends out instead of in.

Sorry I don’t know the Sketchup tutorials by heart, if you post a link to what you are watching it’s easier for people to help or better yet post your skp file here so we can take a look.

The offset tool will move in either direction in or out. To enter direct dimensions, select the shape you want to offset with the tool and drag in the direction you want to go, then click to finish that direction (in or out) in any size, before touching anything you can enter your desired dimension and press return.

Tip: No matter which way you started the offset, - before a dimension will move it that number in the opposite direction

Thanks.

I have found a workaround. In the video, the amount of the offset is entered as a number, 1/2". In my example, following along with the video, entering that amount pushes in the wrong direction.

It turns out that entering -1/2" pushes the correct direction. The only issue now is why the video has you enter a positive 1/2" when it needs to be -1/2".

Here’s the video: https://www.sketchup.com/learn/videos/826 at about 7:00 minutes or slightly earlier.

You can run the offset in either direction with the mouse. Just click on an edge and drag it the way you want to go. Then type the distance. No sign required. That’s not a work around. It’s the way the tool is designed to operate.

2 Likes

I’m not seeing that behavior here.

I do the offset, as in the video, with the offset within the window frame. This looks correct. But, if I put a number (without a sign) into the measurement box, it offsets “out” instead of “in.”

Are you clicking to finish the move before entering a number?

I can’t look at the video right now but try this as an example.

Draw a rectangle.
Get the Offset tool.
Click on an edge and drag the cursor toward the inside of the rectangle.
Let go of the mouse and type a distance value. Don’t use a sign. Just type the number and hit Enter.
Undo the offset and repeat the above but drag the cursor toward the outside instead. Let go of the mouse and type in the distance. Again, no sign is required.

I can’t post a video of my screen right now but I’ve done this several times in the last few minutes to ensure I wasn’t leaving out a step. It works as expected every time.

No.

I start the offset by clicking the mouse, making a new rectangle within the frame.

I release the mouse when it looks correct, then I put the desired number into the measurement box, and then hit the Enter key. (This is the edit to correct my description.)

This is the point at which the “inside” rectangle goes “outside” the original frame. Again, entering the number as a negative amount make it look correct.

1 Like

Something is fishy here, that’s not how it works for anyone else.

Ahhhh… release the Mose button first.

I just did this. For me (Mac version), entering a number works the opposite of what I’d expect, with only a negative amount making it “right.”

So you still haven’t tried it the way I suggested. Let go of the mouse button before you type the number. In fact you can click on the edge and release the button before moving the mouse. It’s the same sort of steps for Push/Pull, Move, Rotate, using the Rectangle,Circle, and Polygon tools.

It’s no different on the Mac or PC using the way I described.

2 Likes

Don’t hold the button single click the line/curve then move cursor in the desired direction and let go of the mouse itself. Then type in offset and hit Enter to finish the operation.

Never hold the button down.

2 Likes

Yes, I described it incorrectly. See my post directly before yours.

Huh, well that a stumper for me. I just tried for 10 min to recreate the behavior your are describing, unsuccessfully. The tool works as expected in 16 pro which I work in, so I opened my copy of 17 pro and 17 make, same deal, works as expected in both. Simply clicking and entering the number works. clicking and releasing and dragging, then entering the number works, clicking and releasing and dragging then clicking again then entering a number works. Even holding the button down which is wrong, worked for me. I’ve never heard of this, ever. Can you send a screenshot of your window or better yet the whole skp file: seventh button from the top in the composing window will allow you to upload.

Yes, I’ll do screen shots and upload them Thursday.

Here are screenshots illustrating my strange problem with using the Offset command with a mouse vs. entering a number in the Measurements box. Unfortunately, as a new user, I can put only one image in a post.

In brief, putting “4” in the box puts the offset rectangle outside the original rectangle, and “-4” puts the offset rectangle inside the original, the latter being the intended behavior.

Your first screenshot shows the outside of the rectangle selected , not the rectangle itself …
Do you select the inner rectangle before activating the offset tool?