Offset click-release-click does not work

Hi,

I am trying to use the offset tool however I have a couple of issues with it. Firstly, it will only work if I type in the dimensions rather than just being able to click.
Secondly, I am unable to copy my previous offset dimensions by double-clicking on another surface.
These combined lead me to believe it is an issue with left-clicking the mouse and the offset tool.
Any ideas on how to fix this?
Thanks

Also just to add, Sketchup has crashed a couple of times while I have been using the offset tool, not sure if this helps

Sounds like pilot error from your description. You should be able to click, release, and move the cursor in the direction of the offset. If you want a precise offset distance you should type that into the Measurements window. After the first Offset is completed, double clicking on additional faces should work. Make sure it’s single faces and not surfaces made of more than one face that you are clicking on.

What were you trying to Offset? Can you share the .skp file?

I’m just following the sketchup tutorial on sketchup campus, so it isn’t any specific object, it doesn’t seem to work on any face, and I’m following their instructions exactly so I may be making a mistake but it seems unlikely by the number of times I’ve tried on different objects yet it just won’t work

I have a feeling it may be an issue to do with settings or preferences but I am not sure

Is the face you’re trying to do the offset on in a group or component? If so, you would need to open that group or component for editing in order to use Offset. (Or make any other modification to the geometry)

No its not in any group or component, I’ve tried the tool on numerous faces but it doesn’t work on anything, the only way I can get the tool to work is if I type in the specific dimensions

I’d love to watch you using it to see what happens. I’d bet my lunch money it’s something you are missing. I have to run to my kid’s school for a little bit but when I get back maybe I can have you show me and we’ll get you sorted out.

I can try and take screenshots to show you, but I promise it’s not me aha, I’ve been using the program for a year or so but now just trying to polish my skills, but yes please any help is appreciated, thanks



In order of screenshots it shows me:
Click the face
Drag the curser into the face
And click again, and nothing happens

You don’t show moving the curser from the line either direction for the offset to know where to put it. My bad I see you moved it inside the door.

1 Like

Are you clicking and releasing before moving the cursor in toward the center or are you clicking and holding?

I have tried both click and hold and click and release, the only way it works is if I select the face, then select the offset tool and use it, however it will only then work on that specific face. To use it again on a different shape/face/object I have to go onto another tool and then back onto the offset tool… which is both extremely inconvenient and time consuming.

You should be clicking and releasing, not clicking and holding.

If you select the face first, you will need to deselect it before you go to Offset another face. Don’t preselect the face.

Here:

Hover over the face with Offset.
Click and release.
Move the mouse toward the center.
Click and release to drop the offset lines.
Hove over the second face.
Double click.

Of course if you want a specific offset distance you need to type that distance in.

Here’s a screen record of what I’m doing, I followed your instructions exactly.

From that video clip I’d say you need to get your computer repaired.

When I type the distance it will work on non pre selected faces, however it often will crash, and the Mac is brand new, only got it a few months ago

Are you using a proper mouse? Not a touch pad or Apple mouse.

Yeah its Logitech, spent £65 on the bloody thing

Just tried a different mouse and it still has the same issue