Offset tool click-release-click mode vs click-drag-release

I have a lot of trouble using the offset tool in click-release-click mode. A lot of the time when I single click, it acts like a click-drag-release except with basically no drag. Placing the offset pretty much where I single click.

Obviously this is mildly annoying when you have a specific distance in mind, so I’m just wondering if there is something I’m missing in how to activate the click-release-click mode.

A copy of my attempts at fumbling is attached. At no point am I click-dragging in this video. While sometimes I find it helps if I try to click close to the edge, in this specific circumstance it does not seem to help.

Have you tried typing in the distance you want and hitting enter?

This happens to me too, sometimes, on a Mac running pro version. My single click seemingly completes a random offset with no opportunity to inference or type. I just live with it and undo until it works correctly again.

Perhaps it’s my mouse, but that has not been a problem anywhere else. I can’t think of any reason it might be happening and would love to know if there’s a solution.

I’ve never had that issue, so can’t really comment.

That’s how I am with most issues people post here, and that’s why you don’t see my comments on them. :slight_smile:

Hey Andy,

I have seen this problem a few times before, but not consistently. Are you using a mouse with a laptop, or a trackpad? I’d be curious to know if you see a different behavior between mouse and trackpad clicks with offset. If not, there is probably something for us to investigate further.

If so, then there may be something related to the sensitivity of the device, but I’d still be interested to know and investigate why this is happening with the offset tool but not others.

Thanks for checking in!

Mark

1 Like

@Box - regarding typing the distance, I haven’t had any luck with that. If you do it before you click, nothing happens. If you do it after you have clicked, the offset has already been applied, so nothing happens again. The behaviour is logically consistent (in my mind at least) with the other ways you type distance. I guess the main problem as I see it is that is that a click-release does not enter the mode I was hoping/expecting it to.

Hi Mark, I am on a laptop yes, but am using a mouse for this. I honestly haven’t tried with trackpad. I don’t think it’s sensitivity related - I guess you are suspecting I am clicking but maybe moving the cursor slightly - as when I’ve tried it I have tried to be very careful not to move the mouse. Using the same level of care with other click-release-click options seems to work as expected.

And yes, it’s a fairly intermittent problem, but when it does happen I don’t seem to be able to ‘get away’ from it - a full restart of my browser (Chrome) does not seem to help.

Not that major any way, I it can be fairly easily worked around with a few more clicks. Was mainly just curious.

Thanks!

It sounds like you are getting an unwanted double click. As I mentioned, it’s not something I have experienced so I don’t really have anything to add.

I’m having the same issue. I’m using laptop and a mouse.
A single click is confused as a double click most of the times.
I’m aware that I can type the distance I want to offset, but there are many times I don’t have or don’t need the specific distance, or I just want to experiment with dragging the offset line to some point.
Is there some setting option that I can adjust for it or it’s just a software malfunction?

I use a Wacom tablet, and this is especially difficult with it. I mostly use the click-drag method as a result. The saving grace for this (and some other drawing tasks) when typing a distance is that you still can. You can draw some arbitrary distance and let go, then type the number for what you want followed by enter, and it corrects what you just drew to that number. In fact, if you don’t like how that looks, you can type another number + enter again and again.

Watch the numbers 4", 12" and 8" being typed into the VCB:


If I really have to use click-click, I’ll turn to the track pad because that does so very reliably.

I’ve also experienced this on the desktop PC version. I don’t know if there is something wrong with the time/movement threshold in this specific tool, but I’ve never seen it in another tool. I think the convention is that if the mouse is released within a certain amount of pixels from where it was clicked, it is considered a single starting click, otherwise a drag operation.

Yes, I am also using those techniques for the most part.
However, sometimes I just work without any specific numbers and would prefer to offset some stuff visually without having to put numbers while trying to find the right number that looks like what I want.
I use Apple Magic Mouse 2 and I’m not sure if it is mouse related but it gets annoying.

I found a behavior that would explain some of the symptoms. If you have your mouse or trackpad, or other device, set to Tap to Click, it’s very easy for a click release to seem like two click releases. That might then make the edge offset by the last offset amount, or in some cases I could do the final release and the line would jump back to the position the cursor was in during the click release, because the tap to click had already seemed like the start of an offset.

So, see if you have tap to click turned on, and if turning that off makes things behave better.