Offset limited for door design


#1

Hi,

I have a project design for a house with sketchup. Whilst designing a door, after doing all the guides, I tried to use the pushpull tool to open the door throughout but was limited to only 0.19m saying “offset limited”.

I checked whether there are any guides but there weren’t any. I noticed that the floor face is blue; I tried to reverse it thinking that maybe this was the reason, but I couldn’t.

I attached the design file maybe somebody would try.
kitchen.skp (2.2 MB)

thanks a lot for your help.

Good day


#2

file not found?
Most likely there is a stray line or something is not quite true. Try turning hidden geometry on and see if the surface has hidden lines on it.


#3

hi gadget2020,

thanks for your reply. I tried but couldn’t find any such lines. I’ll try to upload it again.

thanks againkitchen2.skp (2.2 MB)


#4

I tried opening the file, but somehow it won’t let me… how can I share a file?


#5

How are you attaching the file?

You can just drag it from your computer into the message window, or use the 7th icon from the left on the top of the message window, or ctrl=g, and browse to the file.


#6

I used the upload button… kitchen.skp (2.2 MB) I’ll try again

I don’t know why but it just won’t work…

please download it from here:
http://expirebox.com/download/e1e4a434e2141a58568368466b7895e0.html


#7

Several of your faces aren’t flat, if you turn on hidden geometry you can see all the edges forming triangles.
The door is hitting one of these edges.


#8

Oh, thanks for your reply. at least the mystery is solved… How do you suggest I go about it? thanks again


#9

Too be honest I would probably start again and use the rectangle tool to lay out your structure more correctly. Use groups and components to separate the geometry then you can move things around and adjust things without twisting the faces.
Start with the floor as a rectangle and make it a group. Then add your walls and group them, cut your doors…


#10

The thing is that the rooms aren’t a rectangle… they are very irregular…


#11

Ok. But start drawing your non square room on a flat surface.


#12

Hello @e_bouvett

I notice you’re painting the model as you build it.
To avoid errors you need to see the geometry you’re working with.
Unfortunately the materials that make the model look nice can also make it difficult to see the Edges (lines) with which you build the model.

It’ OK to paint the model as you go along.
But you’ll have an easier time working in Monochrome Face Style as you continue building the model.
Click … View > Face Style > Monochrome
Now if you view the model in Monochrome and turn on Hidden Geometry you’ll see a number of errors.
Click … View > Hidden Geometry

Notice the floor is distorted and the adjacent wall is distorted.
In the attached image the endpoint coordinates displayed by the Text tool indicate geometry in the area around the doorway has been moved up and out a bit.
SketchUp then automatically broke the floor and wall faces wall into multiple faces.

There are a few faces are reversed as well.
The backside (bluish gray) should face inward. The front side (white) should be facing out.
Simply right context click on the face > Reverse Faces