Odd behavior when trying to edit/resize a component

I have found the ability to resize a Component (such as a fairly simple box-like object) – by selecting it, doing Edit Component, putting a rectangle around one end, and moving that end to resize the object – extremely useful. It has also worked to simply triple-click the Component to make it editable.

Unfortunately, it seems that the selection of the surfaces to move has become quite erratic.

Usually, only the lines and planes of the Component which are entirely included within the rectangle will turn blue and become movable. This is the behavior I expect.

But sometimes all lines and planes partially included within the rectangle will also become blue, and no resizing is possible.

Finally, sometimes nothing will turn blue or become editable.

This inconsistent behavior also shows up for Groups. Solid vs non-solid objects – it happens with both. When I edit Components, I make them unique first.

Occasionally the rectangle process fails to work on one side of the object, and then works fine on the opposite side of the same object. Strangest of all, it can fail to work on an object, and then a minute later it will work on the same side of the same object.

Is this due to lags in processing? I’m doing this on a i7 laptop connected via WiFi to a 1 Gb fiber line. My model size (when downloaded as a .skp) is a little over 1 MB, and updates are occasionally laggy. Could that be causing problems?

Any advice is appreciated, thank you.

Left to right will select only that which is inside the solid selection fence.
Right to left will select whatever the dotted selection fence touches.
Triple click will select all connected geometry, so can be an issue when you triple click a group/component.
Double click will open a group/component for edit (the third click will tend to select everything inside as well rather than just opening it for edit.

Thank you, I will give that a try. I’m not sure I ever noticed whether the selection fence is solid or dotted.

That worked!! Thanks much!