Objects from 3D Warehouse taking forever to load or crashing program

I just downloaded Sketch-Up Pro 2020 from 2019 and every time I try to download an object from the 3D warehouse it takes 1 - 3 mins to download and / or crashes the program. I’m on my own internet and I have 16GB of Ram and I’m on a less then 6 mo old macbook w/ 1TB of internal memory. I have used sketch-up a lot on this computer and have never had this problem till now. It’s usually super fast for what I am trying to do. I’m drafting some sets for film builds - so its all one to three walls with limited details. Not trying to draft a complicated model but this is really slowing me down and becoming quite frustrating. Even when I open a new model with nothing drawn on it yet, I’m still having this problem.

Anyone else experiencing this? Any advice?

1 Like

Check what your system preferences, iCloud Drive options are set to. If you are synchronizing Documents & Desktop, that can lead to very slow downloads, because the file is synched back to iCloud, along with everything else that is being synched. Turning that option off will speed things up a lot.

Note that when you turn that off, some local files will vanish, but are still in the iCloud Drive copy of that folder.

Hmm I tried it and it didn’t work. It’s still taking FOREVER for items to download. I have tried copying the file and saving it to a different location.

Does it take a long time to download the same object if you go to https://3dwarehouse.sketchup.com/ and save it to your computer?

It takes just as long to download the same item.

This works if I download it from the website and then copy / paste it into my model.

It takes as long to download the object in the web browser even if Sketchup isn’t open?

Oh no it actually downloads very quick from the web browser - that actually works as a workaround. (and is getting me through this project tonight, so thank you!).

I just can’t re-download the same item from the 3D warehouse once Im in SKUP.

Inside this folder there is a WebCache folder. You could quit SketchUp, delete that folder, and open SketchUp. It might help with some caching issues:

~/Library/Application Support/SketchUp 2020/

You can get there by putting that text into Finder’s Go menu, Go to Folder… menu item