Object does not Snap to Grid

I tried moving/copying the shelf to the grids but it doesn’t attach to the grid like the top end of the leg, unfortunately it slips through the grid lines except for the top grid as that’s where it attaches to the leg’s top end.
Is somewhere an option that needs to be activated to snap to grid line?

probe.skp (19.1 KB)

It snaps on my sketchup.

1 Like

What version of SketchUp are you really using? Your profile says Free Plan 2022 but there is no such version.

You have added several guide-points to the model.
You can snap to those points using the inference locking keys etc.
But if you want a more general ‘guide’ then you should use the tapemeasure tool to make guide-lines…
What appears to be a short horizontal guide off your existing points is not snap-able, unlike the point itself…

1 Like

Yes, your SU is working nice so my problem is probably is interference between version 2023 and Windows 7.
I tried with infinite gridlines instead of these short horizontal guides and Snap to Grid finally working!

thank’s for help!