Nvidia Titan RTX Running SLOW - SU 2019 Pro

I just completed a new PC build which includes the following:
*Windows 10 Pro
*Intel core i9-7920X (12 cores)
*32Gb Corsair DDR4 RAM
*1TB Samsung 970 Pro M.2 SSD
*Nvidia Titan RTX GPU

I downloaded the latest version of SU19 Pro (19.1.174) thinking this thing should be able to eat its lunch. But SU still runs like it’s on a 10 year old machine!’

I’m using a 350Mb model (with about 800 different materials pulled from Podium’s Material Browser). Again, this PC should be able to handle it, but I have a tremendous amount of lag in moving around the model. Also, Podium V2.5+ and Podium Walker GPU are running painfully slow or crashing.

Can someone please help??

To confirm the basics -

SU recognizes your GPU?
NVIDIA control panel set correctly for SU?
On a brand new machine, I would assume the GPU driver is the latest?

Working practices with SU -
Parts of the models hidden on their own layers when not in use?
800 materials is possibly outside the norm even for that size model, do you work without textures visible sometimes?

If all that checks out - try uninstalling Podium / walker and see if it is the issue.

Thanks for the quick reply!

SU does recognize the GPU
Not sure what settings need to be specified for SU within the GPU control panel
GPU drivers are latest (March 20th 2019)

I do use a lot of layering for hiding objects, and I prefer to keep textures on, but going to white box view doesn’t seem to help

Dumb question - but there’s not some sort of plugin for SU that allows it to utilize more of the processing cores is there?

Sorry - no extension re core use.

Like most 3D apps, a lot of the processing is single threaded so more cores does not help for specific operations - it does help with all the background windows services and other multi tasking.

make sure you CPU has Intel turbo boost running and check the task manager to see if the CPU is then running up to 4.3 GHz.

NVIDIA control - manage 3D settings>program settings>drop down select NVIDIA GPU for SU and Layout individually.

12 cores don’t help für single-threaded applications as CAD systems, a i7-9700K for ~35% of the cost would be approx. 20% faster…

Definitely close the “Outliner” tab.

If you wanna get the last bit of performance you might want try to set the processing priority of SU via the Windows Task Manager to “Realtime” (“Win+R > taskmgr > SketchUp.exe > right-click > Set Priority…”).

be aware, that realtime is not realtime :wink:

A - Does this mean that Sketchup will never be able to take advantage of the now-ubiquitous Windows machines with many core’s (mine is a Ryzen 7 with 8 cores)
B - Is there any advantage to what I have been doing which is to go into the task manager each time I load a complex project and Assigning the project its own core via the details/affinity tab?
C - is there a way of forcing Sketchup/Windows to hold the whole project in RAM?

So far no 3D software has been able to take advantage of multi core cpus. It’s not just sketchup. Also, it’s not just windows PCs that have multi core processors, and they have been ubiquitous for several years.

1 Like

All True BUT…!..?

  • Is there any advantage to what I have been doing which is to go into the task manager each time I load a complex project and Assigning the project its own core via the details/affinity tab?

  • is there a way of forcing Sketchup/Windows to hold the whole project in RAM?

I don’t know but I’m pretty sure your computer is fine and the processor is the possible bottleneck. Consider using settings in sketchup to make things faster and start modeling with more efficiency.

A - pretty likely at least for modeling operations, shading/rendering or file operations is another thing.
B - nope, the used core is not relevant but you may want configure the priority to the highest, at least if you wanna do some ‘number crunching’ as e.g. importing mesh formats w/ high-poly content.
C - should be the default, swapping to the disk is not required with enough RAM of halfway recent systems.

1 Like

Much Thanks

B - it seems to work a little I give Sketchup its own core and all the other muck (Outlook/Word/Excell/adobe reader) plus of course LayOut. seem to not Clag up as much…I think? I was suspecting Sketchup was stuck in the 1st core sharing it. things SEEM? to be going faster CPU is running at a much higher percentage but the workflow is better???
C - 16GB of ram about to be upgraded to 32GB of faster memory, I was getting warnings about sharing, I think with the C drive SSD.

perhaps it’s the graphics card, it has only 3GB??

again…much thanks

It’s your CPU. It’s not bad it’s just that you’re pushing it to the limit with your complex model perhaps. Settings in software can also help things move quickly while you work, such as turning off shadows and layers/tags that you don’t always need on.

again, not sticking it to a dedicated core but increasing the priority by r-cklicking “sketchup.exe” etc.

I am turning as much off as possible using scenes/layers etc

the project includes a number of complex components which are separately drawn for manufacture but then imported into the overall project model. perhaps there is some kind of simplification that can happen to those components can be used in the larger model but Sketchup doesn’t have the detail of each M10 thread used, when I can’t even see that in the overall project but its incredibly useful to adjust the minutiae of an individual unique component

I right-click Sketchup for priority, I just wish it would stick and I didn’t have to do it each time I open a project!

Does it make a difference in performance when you do? I find it hard to believe you would have to do this with so many cores available. Your issue is most certainly primarily with the heavy model and not your hardware or memory allocation.

the CPU priority has nothing to do with the available kernels but the amount of time slices the application is provided with by the OS regardless of the kernel used. The effect is not pretty strong, therefore my annotation that it’s primarily useful if long tasks of ‘number crunching’ planned.

• SketchUp Help Center: Improving Performance