Nvidia P1000 video card and SketchUp warning message

New computer w/Nvidea P1000 video card, Windows 10, SketchUp Pro 2020
Every time I start Sketchup I get this message: “Sketchup has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. Sketchup will perform better if you change your system to default to the AMD/Nvidia card. See help center article for more information” (which references to another unhelpful article).
Neither article has anything that helps…
What’s going on? How to fix?
mg

That is done in the Nvidia control panel. Right click on the desktop, it is in the context menu.

Mine does not look like that at all.
It does not have a Manage 3d settings.
I’ve updated the driver, no joy there.

The Nvidia Control Panel should be in the context menu when you right-click on your desktop.
If you went there that way, what does yours look like? Don’t you have the “Select a task” tree on the left?
Where did you get the updated driver? Did you go to the Nvidia website?

Lenovo said I needed DVI adapters for my monitors, so they sold me two when I bought the machine.
Turns out the DVI ports are to the onboard graphics, not the NVIDIA graphics.
NVIDIA uses mini display ports.So today I went to Best Buy, got the correct adapters and now all is good.
SketchUp is happy.
Thank-you for the kind responses.
mg

Hey Askin_Questions, it sounds like your problem was monitor related. This is what I suspect is happening to me as well. After I got my new HDMI monitor, whenever I start sketchup, I get the message about multiple graphic cards too. How do I know if I got a DVI port or not?

First, open the Nvidia control panel 3D application settings and make sure that SketchUp is set to use your RTX card, not automatic selection.

If that doesn’t help or you have other kinds of display problems you can start messing around with cables and plugs. For instance, I have met systems where using HDMI cables don’t give you full resolution on a 4K monitor.

DVI is sort of old technology today. It uses a large plug with screws. Most current monitors use either DisplayPort, HDMI or Thunderbolt (USB-C) connectors. If your computer is a desktop, you should primarily be connecting your monitor directly to the ports on your RTX card. My RTX card has only DisplayPort connectors, so if your monitor has only HDMI, you will need to use a cheap adapter.

When I open the Nvidia control panel, all that’s under the task tree is Developer, and under that is “Manage GPU Performance Counters”. I think the settings for RTX is different from the version you got.

I have used many different Nvidia graphics cards, also a few Quadro ones, and the control panel looks the same for all, with minor differences in parameter names. This is from my RTX card:
image

Mine does not look like that. My graphics card is a GeForce RTX 2060 btw…

Do you open it by right-clicking on your Windows desktop and selecting it from the context menu?
I wonder if you have a correct driver installed. You might go to the Nvidia website and download and install the latest driver for your card type.

I right-clicked on the desktop and selected NVIDIA Control Panel. This computer is only 11 moths old.

What I read from the Internet suggests to me that you are using some kind of developer tools, not a regular Nvidia driver. Does your Nvidia control panel have a System Information button? What does it say about your driver version?

BTW, if you have never upgraded your Nvidia driver, it might be the time to do so. An 11 months old computer might have a driver version that was current when the computer model was launched by the manufacturer, sometimes even years ago. My driver starts to be a bit old, but as I see no problems I haven’t upgraded it just for the fun of upgrading. But that is the first thing I try always when any problem with 3D applications arises.

How do I update my Nvidia driver? BTW, what’s a system information button?

The System Information button is in the lower left hand corner of the Nvidia control panel dialog, and also in the Help menu of the same. It pops up a window that tells about your driver version and other settings.

I update my driver by going to the Nvidia website ( Download Drivers | NVIDIA )
I enter my graphics card details in the search form and download and run the installer application the page suggests. If your computer is a laptop you might try first the latest driver supplied by your laptop manufacturer. Automatically installed Microsoft-supplied drivers are not recommended.

My computer is a desktop.