Why is the model being displayed differently?

I’m using Dell U2713HM monitor. I dont know why its only happening on one pc but runs perfectly on the other pc.

the straight lines are shown as curve.

PS im using a 2070 Super and using Display Port cables

this is the other pc, as it should be. straight line.

Looks like a graphic card issue, but usually NVIDIA are very solid. You could try SketchUp > Preferences > OpenGL > use fast feedback. If it’s currently on, try it off, or vice versa.

Well… i tried that but it didnt work. it actually gotten worst. The graphic card is just a few months old.

It looks like the moiré effect and one graphic card is able to cope with it better.
Check the setting for Anti aliasing in the Opengl setting, setting it higher should reduce the effect, but you may be limited by the cards capabilities.

Further reading…

Thanks for the advise, i will give it a shot and post an update. Have a nice day.

Thanks, i will give it a read, hopefully it will solve my problems.