Graphics card selection

No response from Trimble on a service ticket (16hrs), I have work to do = I’ll try here.

Acer Nitro 5 gaming computer with NVIDIA Geforce RTX, Win 11.

Opening Sketchup, I receive a notice that I’m not using the NVIDIA card, and it is strongly recommended I do so for best performance. (DUH!)
Okay, I’ve identified an Intel card present in the laptop. Remedy suggested: ENABLE the NVIDIA card.
It is, and has been since I bought the laptop.
Okay, Let’s disable the Intel card, in an attempt to force it to use the right one.
New Message: You’ve not set up your video card for accelerated performance = Sketchup cannot run.
Check the status: Yes, it IS and always has been set with the accelerated performance option.
Okay, go back, re-enable the Intel card. Now, at least Sketchup (2023) runs.

How do I get Sketchup to recognize and use the NVIDIA card that is required to run the program properly?
Just trying to obey Trimble’s dictation on how to properly run their app.
Help, anyone?

There should be a NVIDIA Control-Panel available to you.
Use that and in Manage 3D Settings there should be a tab,
Global-Settings lets the app decide.
The other tab is Program Settings [it might take minute to be populated]
In the drop-down list find SketchUp [if it’s not there add it], and see what’s set up…
The SketchUp Preferences should also point at your OpenGL NVIDIA gc…

TIG: thank you for the quick response. I have worked my way to that realization, but sadly, have discovered I cannot open the NVIDIA control panel app. I’ve also researched and found I may need to right click that icon and “run as administrator”. This failed to open the control panel as well.

Remedy: called NVIDIA tech support, found out I need to use their clean up tool, install a specific new driver (Studio version, not Gaming) and their control panel app. Once that’s done, I can open NVIDIA control panel, select Sketchup and direct Win11 to always use the NVIDIA card when opening Sketchup, as you were correctly describing. Why the NVIDIA panel was inoperable is anybody’s guess.

FWIW: While running an external monitor, the HDMI is connecting direct to the NVIDIA card, and Sketchup ran fine for me. These problems only came up when working remote, with a client, while using the laptop’s integrated display, which wants to run on the Intel card. Hence, the confusion, and as you can imagine, something that appeared to be buggy behavior of Sketchup, which was not actually the case.

Hope this helps anyone else struggling with similar issues when using a laptop to run Sketchup. This was NOT a Sketchup problem, but internal systems corruption, that appears to have simply been a poor factory install (?).
In conclusion, I’m glad Sketchup alerted me to this problem, and I can actually enjoy using it again.

I know that at this point support replied to you about six hours ago. Might have been close to when you posted!

Selecting the right GPU has always been tricky, and could lead to difficulties. In SketchUp 2024 you can now choose which GPU you want to use.

It may be worth trying 2024, it does have some other improvements in it as well.