Nvidia OpenGL drivers loses connection due to time-out, crashes


#1

Win 7 64 bit, core i7, 24GB RAM, Nvidia GT 620. Installed SU 2015 64-bit and continued working on a 32 MB model from 2014. Turn on shadows and screen goes black, then get message “The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue. The application must close.” Installed the newest Nvidia driver and rebooted. Even with 64 bit version, I’m finding that model is very slow and jerky to orbit with shadows on - no better than before - and now this new problem with exceeding the time-out limit and crashing. Any suggestions on how to fix this and improve performance with shadows on?


#2

@stevehausz

I have a few ideas on how to fix this, but it may require an edit to your Windows Registry. Are you comfortable with that?

~Drew


#3

Drew,

    Thanks for your interest in my plight!  I haven't ever delved
    into my registry, leaving that sort of under-the-hood stuff to
    my computer guy, though he's not a SU user.  The window that
    popped up to announce that the time-out had been exceeded
    provided a link to Nvidia's site for more info, including the
    suggestion that one could go into the registry and increase the
    time-out beyond the normal 2 seconds.  If it's not too
    difficult, I'd be happy to have you walk me through it, but I'd
    be especially interested to know why orbiting in the new 64-bit
    version of SU is no better than before, and is in fact causing a
    crash.  If you'd like to walk me through the reg edit, should I
    start by creating a restore point?




    Thanks,
Email signatureSteve Hausz, Architect

829 De La Vina Street

Suite 300

Santa Barbara, CA 93101-3295

Phone 805-962-7478

Cell 805-886-2513

Fax 805-899-2900


#4

@stevehausz

I will be happy to walk you through. I will give you a quick caveat, however. The Registry can be a bit tricky, so please don’t change anything outside of the instructions, as you risk corrupting the registry, and consequently, your computer.

You are absolutely right about the first step. Create a restore point, if you know how. If not, I can walk you through that as well.

The second step is to select the Start button, and type “regedit” (without quotation marks) into the search. An application for the registry should pop up in the list. Right click it and choose 'Run as Administrator." This should open your registry.

Next, we will search for a specific registry key:

HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>GraphicsDrivers.

This is done by following the arrows (>). Click on HKEY_LOCAL_MACHINE, then SYSTEM, etc.

When we get to the correct registry key, right click and select to create a new key REG_DWORD, and name it TdrDelay. The value assigned to it is the number of seconds before TDR kicks in - it is currently 2 automatically in Windows by default.

Change the value to 4, instead of 2.

Exit the registry editor, saving if prompted (remember that we should have a backup restore point already) . Restart your system, and see if the problem still exists.

Let me know if this helps, or if you get stuck.

~Drew


#5

Got the
restore point done, regedit open, got all the way to Graphics
Drivers, then I’m confused by the directions. Do I right-click
on “graphics drivers”? I tried that, context
menu>new, but not sure what to do next. Am I naming this new
key REG_DWORD? Or TdrDelay? I tried both, but not seeing anything
about values. As I type this, I see that at the moment, I have
the new key named TdrDelay, but graphics drivers is highlighted,
and in the main window, there are two entries…

NAME

TYPE

DATA

(default)

REG_SZ

(value not set)

DxgKrnlVersion

REG_DWORD

0x00002005 (8197)

  I just right-clicked on the TdrDelay key I created, and under
  "new", there was DWORD (32-bit) Value.  That seems consistent with
  your directions.  Now I see:

NAME

TYEP

DATA

(default)

REG_SZ

(value not set)

New Value #1

REG_DWORD

0x00000000 (0)

  I'm not seeing a current value of 2 though, if in fact I should. 
  Did I get off track?  What do I do next?




  Thanks,
Email signatureSteve Hausz, Architect

829 De La Vina Street

Suite 300

Santa Barbara, CA 93101-3295

Phone 805-962-7478

Cell 805-886-2513

Fax 805-899-2900


#6

@stevehausz

Apologies. I was responding from my phone, from memory. I will give more clear direction in a few minutes when I get home and to an acrual computer.

~Drew


#7

@stevehausz

Sorry for the delay.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\GraphicsDrivers
On the Edit menu, click New, and then select the following registry value from the drop-down menu specific to your version of Windows (32 bit, or 64 bit):

For 32 bit Windows
Select DWORD (32-bit) value.
Type TdrDelay as the Name and click Enter.
Double-click TdrDelay and add 8 for the Value data and click OK.

For 64 bit Windows

Select QWORD (64-bit) value.
Type TdrDelay as the Name and click Enter.
Double-click TdrDelay and add 8 for the Value data and clickOK.

Close the registry editor and then restart your computer for the changes to take affect.

See if that is more clear. If not, we will take it a step at a time. I will be here until we get this squared away for you.

~Drew


#8

On a walk with my wife at the moment, will be back in the office soon.


#9

OK, got back
and completed those steps, and rebooted. Opened 2015 and the
file I had problems with. As soon as I turned shadows on, the
screen went black, and I got the same message about the OpenGL driver.
If anything, I’d say it reacted more quickly than before.

    I did open regedit again, and see the value of 8 that you had me
    enter, so that did stick.  Gotta stop for tonight, but tomorrow
    I'd like to send you some screen shots of what I did in regedit
    so you can confirm that I got it right, before we try other
    things.




    Thanks ever so much for your help!




    Regards,
Email signatureSteve Hausz, Architect

829 De La Vina Street

Suite 300

Santa Barbara, CA 93101-3295

Phone 805-962-7478

Cell 805-886-2513

Fax 805-899-2900


#10

@stevehausz

Understood. I will think more on it tonight, and we will work on it again tomorrow. I should be around in the afternoon MST. If I come up with other options, I will post them before then. Either way, we will find a solution for you.

~Drew


#11

the reason why you display output speed is sluggish can be found here.

if using a desktop system switch to something capable as e.g. a GeForce GTX 750 Ti (or better).


#12

A big plus one for this card from me. Had to replace my ancient GeForce 8800 GT and picked the GTX 750.


#13

@stevehausz

Okay Steve. If we can’t get the graphics card to behave itself through the registry, we may have to adjust the settings in the interface. Let’s try this:

Go to NVIDIA Control Panel (right click on an empty space on your desktop. It should be one of the options in the menu) --> Manage 3D Settings --> Global Settings, and switch “Power Management Mode” to “Prefer Maximum Performance.”

Let’s see if that does the trick. I will be digging in to other options, just in case.

~Drew


#14

do recommend the MSI ‘Twin Frozr’ series which is very silent.


#15

That certainly does shine some light on the problem. :wink:

Given what we know of the problem it seems the driver and or card is not up to the task of modeling with shadows displayed. Perhaps there are other unnecessary rendering effects displayed as well.
(you didn’t say)

Modeling technique has a tremendous impact upon performance, regardless of hardware capabilities.
You may find these articles at the Sage helpful with both aspects of the problem.

How do I make SketchUp run faster?
A compendium of performance modeling techniques.

Graphics Card Issues
Background information and solutions to graphics issues.


#16

more of this stuff also at the offic. SU Blog:

Speed Up SketchUp: Extrude curves with fewer sides
Speed Up SketchUp: Use Fast Styles

hiding stuff (by using layers) not needed during modeling as e.g. heavy 3D components and disabling eye candy as x-ray, fog and shadows etc. may help too.

using a slow video card, reducing the anti-aliasing in “Window > Preferences > OpenGL” to “2x” could be evaluated also.


#17

Thanks everybody, for your invaluable input. I started off today by restoring the system to before the regedit. After that, I opened the file I was having trouble with yesterday, and have had no crashes, despite trying to do the same things that were problematic yesterday! It’s not even as jerky in orbiting with shadows on as it was yesterday, and interestingly, that doesn’t seem to change as I switch from Shaded with Textures, to any of the other less intensive modes. FYI, I do make extensive use of layers, groups, components, simple styles when I’m modeling, etc. Yesterday’s problem seemed to arise only when shadows were involved. Sometimes when trying to orbit once shadows were on, or trying to change shadow settings, and once just by turning them on.

I used to have a Quadro GPU as that’s what I thought I needed for CAD work, but switched to the GT620 a couple years ago. Doing some Googling this morning, I became familiar with Passmark, and am indebted to sketch3d_de for the link to the comparison of my 620 to the top 10, showing its abysmal performance. I know that physical space inside my box is a constraint for which cards I can use, but I think a better card would be a worthwhile investment, unless anyone has an opinion otherwise.

Per Drew’s recommendation, I made a change in the Nvidia Control Panel. Below are screen shots of the current settings, both for global and program settings, scroll up and scroll down…

(I’m told new users can only put one image in a post, so I’ll try a post for each of the other 3)

Thanks again to all of you!


#18


#19


#20

@stevehausz

A new card is almost always a good idea, especially if you are doing anything graphics intensive.

Glad you got everything squared away. Let us know if you need anything else!

~Drew