Nvidia geforce gtx 950m poorer performance than integrated Intel

nvidia
#1

I bought a new Acer Aspire F15 with Nvidia Geforce GTX 950m graphics card specifically for SketchUp but when I select the Nvidia card for SketchUp in the Nvidia control panel, SketchUp performs much worse, with sticky, slow changes when moving around a scene. Is there a setting that I’m missing somewhere?

0 Likes

#2

It could be due to the operating system. There are a lot of reports of recent Win10 updates causing problems.

You should also make sure the graphics drivers are up to date and that SketchUp is actually being displayed by the nvidia card and not integrated Intel GPU.

0 Likes

#3

Hi Dave,
the graphics drivers are up to date. When you say I should make sure that SketchUp is actually being displayed by the NVidia card and not the integrated Intel GPU do you mean within the Open GL tab of SketchUp preferences or within the Nvidia control panel? Both say NVidia
Thanks
Jamie

0 Likes

#4

In the nVidia control panel.

Read through the forum and look at other posts in which people report sluggish behavior.

0 Likes

#5

Will do, thanks

0 Likes

#6
0 Likes

#7

Hello,
I have a Acer Aspire V
i would like to run sketchup on my integrated Nividia GeForce GTX 960M
Always when i try to start it on this Card its not working well
SketchUp Chekup recognize an issue with the GTX that there is not enough memory available.
Does somebody have a solution for this?

0 Likes

#8

@Dan - selection tool process is slow - solution KB4013429, from my experience (also in that thread);
In win10 not all updates are shown or can be de-installed. Almost seems like after a major update the history is deleted or reset. I tried several ways to de-install that KB. Didn’t work. What did work for me though was updating the intel HD driver. Issue seems gone now.

0 Likes

closed #9

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.

0 Likes