Numbers of keyboard not working well in SketchUp 2021

Hi there!

Since I’ve been using SU 2021, my keyboard numbers are not working proper as it use to do.
When I try to use 5 on my right side of my keyboard, it won’t work, the normal 5 on top will.
Does anyone has the same problem or what may be the problem?
It’s very annoying, because I use that side a lot for distances.

Does your keyboard have Num Lock?

It does sound like you’ve turned off Num Lock.

Nope, Num Lock is on, and I’ve tried turning it on and off, but still the number 5 doesn’t work :slight_smile:

If you open the Calculator do those numbers work?

Yep and in Excel or Word it works

SketchUp shouldn’t affect the keyboard but did you install SketchUp correctly by right clicking on the downloaded installer and selecting Run as administrator?

I never done it that way, I installed the normal way.
The previous versions of SU (2019 & 2020) didn’t have this issue.
I can try it by installing it again and see of it helped.

1 Like

Numerous posts here on the forum have taught us that installing by just running the installer exe is a hit-or-miss proposition. Some people do it and never have an issue. Others encounter all sorts of strange errors while running SketchUp that seem to be related to permissions, often on items in the Windows registry. So far as I know, there have been no reports of these kinds of problems from someone who did a right-click Run as Administrator. So the best advice is to do it that way regardless of whether you had success in the past when doing it the other way

1 Like

As Steve indicated, there are all sorts of odd problems created by incorrect installation of complex applications like SketchUp. It seems to take just the right combination of events to make those problems show up.

If you are going to reinstall, use the Run as administrator option.

I’ve been using the number pad on this extended keyboard for more than 6 years with no problems including with SketchUp 2021.

I’ve found it!
The numbers 5 & 7 of the Numpad were assigned to my Trimble Scan Essentials app in SU 2021.
They were assigned as shortcuts haha…
I didn’t know I did that.

1 Like

That’s not something we would have ever guessed. Probably a good idea check the rest of the keyboard shortcuts to see if you’ve assigned other keys you shouldn’t have.

Haha Yes I will… Thanks for replying :wink:

Have you set up these shortcuts? I’m thinking there could be an issue here if SU ships with number keys as shortcuts.

1 Like

I just tried installing the extension, and none of the 12 possible shortcuts have a value already set. Hopefully David set it manually some time ago.


I’ve set the shortcuts myself. I was testing it so I could use the plugin easily

1 Like

Thanks for confirming this!

1 Like