Number / Numeric Entry Not Working

Numeric entry has stopped working altogether. I cannot enter any numbers or measurements into Sketchup. The number pad to the right is only responding as shortcut keys (ex. 9=pg.up , 3=pg.dn, etc.), and the number keys along the top have stopped working as well. I have tried NumLock. I have tried closing and re-opening Sketchup. I have tried resetting the computer. I have reset all shortcut values in the preferences window.

I’ve searched this forum and on Google, and I can only find threads where NumLock was the culprit.

The number entries work fine in other programs (both the top number keys and the number pad keys).

Sketchup seems to be the weak link here. Can anyone tell me what has happened?

Currently using Sketchup Pro 2019 on Windows 7 Pro.

You aren’t clicking in the Measurements window before trying to type the numbers are you?

When you installed SketchUp 2019 did you right click on the downloaded installer and choose Run as administrator?