Numeric keypad "0" key not working for input field

sketchup
advice
bug

#1

The input field will not accept a zero when using the numeric keypad. All other numbers from numeric keypad will work in the input field. A zero will work using the normal numbers on the keyboard. The Zero will work from the numeric keypad when inputting dimensions into extensions. I have noticed that when I hit the zero key from the numeric keypad that the outliner from the default tray will “flicker” for a split second but nothing else happens. I have tried to see if the zero key is associated with a shortcut but have found none. The zero key from the numeric keypad works in all other programs and apps. Is anyone else having this issue?

I am using Sketchup 2018 Pro and I am using an Acer Aspire V17 Nitro running windows 10.


#2

Not an issue in SU2016 Pro on Win 7.


#3

Zero on the numeric keypad works fine here, too. This is in SU2018.


#4

There is no apparent issue with the zero key on either of the two computers I currently use to run SketchUp Pro. I’m using versions 2018 and 2017.

Is it possible that you may need to toggle the NUMLOCK key?


#5

It’s weird the NUMLOCK is toggled because all other numbers work when using the numeric keypad. Thanks for the idea.


#6

Whenever you get a weird hardware error, cross-check by testing another known good device.
So, plug in another keyboard and see if that one works ?

Secondly, check for newer device drivers.

Thirdly, see if extra hardware utility is interfering with proper device operation.


#7

Are youtrying to set the angle to 10, 20, 30 etc or to 0 itself?


#8

Nope, its just the input box will not recognize the “0” key from the numeric keypad. The input box recognizes all other nunbes.


#9

I’d be looking at trying a different keyboard.


#10

Yeah but the “0” key works in all other applications i.e; web browser, Word, Excel, including extensions within Sketchup that need numbers for say wall heights. It is a head-scratcher.


#11

It doesn’t make any sense that a single key wouldn’t work.

Out of curiosity, when you installed SketchUp, did you right click on the installer file and choose Run as administrator. Other very weird things have been reported by users who didn’t install SketchUp with Run as administrator. Maybe it’s worth trying it now and selecting the Repair option.


#12

To be honest I am not sure if Sketchup was installed as administrator. I’ll check it out and try it. Thanks.


#13

Really the only correct way to install SketchUp is to do the right click and Run as administrator thing while you are logged in as normal.

Anxiously waiting your results.


#14

Might not be for a day or so. Thanks again.


#15

Great! I won’t sleep tonight.

:smiley: :smiley: :smiley:


#16

lol, The “0” key does work in Layout.


#17

Weird!


#18

You’re telling me.:confused:


#19

UPDATE: I actually had an extension shortcut to my numpad 0 key. I deleted this shortcut and now it works. Thanks for all the replies.


#20

Well, that explains it. I never would have guessed that.