Nothing but problems with Sketchup Mac 2016


#1

I am now totally disgusted with Sketchup 2016.
After 12years of using Sketchup, I have had more problems with the 2016 version than all previous versions combined.
This is supposed to be an easy-to-use 3D modeler.
Back in 2004, I was going full blast with this app within two hours of downloading it.
Now I’m spending hours just trying to get past problems so I can use it.
I can’t even remember all the problems and workarounds I’ve had to go thru since I downloaded v2016 in Oct.
I’ve finally decided to kill v2016 and go back to v2015 where I can get work done instead of wrestling with the program.


#2

Maybe sometime you will have the time and energy to list a few of the problems you encounter with SketchUp 2016, and then can get some feedback from other folks about it. I’ve been using SketchUp 2016 for the Mac pretty intensively for the past 12 or 13 months (with OS 10.10 and 10.11), and I’m pretty happy with it (compared to other versions of SketchUp, starting with 8). I probably use it 10 to 15 hours per week, for what that’s worth.


#3

What sort of problems are you seeing? I’ve been running 2016 (after 2015) on mac since release. I generally don’t have many issues and I’ve never used the win version so no comparison. I’ve only really had probs when I’ve upgraded the OS a bit quickish (like the second it’s out). But would be interested to hear your experiences.


#4

Yesterday was the two straws that broke the camel’s back.

  1. All the interference points disappeared… no corners, no midpoints, no projection lines. I quit everything and rebooted. Still no interference points. I uninstalled Sketchup 2016 and trashed every sketchup file and folder in the system. Then reinstalled. Still no interference points.
  2. Colors and textures quit pasting between windows. See my thread by searching on 'colors-in-model.'
    All this in a single day… and the previous three months just as unhappy.
    I’m running on a clean install of Yosemite and I have no problems with any of my other frequently used apps.
    Now that I’m running SU 2015 again, NONE of these problems are showing themselves… everything works.

#5

What’s your machine?


#6

Also Im unsure of Yosemite compatibility, 2016 was developed and released under El Capitan.


#7

I’m on a late 2009 Mac Mini Core 2 Duo with 8GB RAM and 240GB SSD, along with 3TB of external drives.
I can’t upgrade to El Capitan because Apple, in its infinite wisdom, destroyed iWork Pages to make it compatible with IOS.
I can’t run the older version of Pages under El Capitan due to justification bugs.
And I use Pages on a daily basis to edit eBooks.
So I’m stuck with running Pages 4.3 under Yosemite… and running Sketchup under Yosemite.
So it probably is a good idea use SU 2015 instead of SU 2016.


#8

I run Pages 5.6.2 and SU v17 on my 2007 iMac under El Capitan…

it’s a free upgrade of Pages that required a slightly odd instal process I found online…

john


#9

Pages 5 is totally useless.
I have at least six show-stoppers that keep me from using it… and probably more that I haven’t found yet.
Top of the list is “Advanced Search” which allows search of special characters such as ‘paragraph break’ and ‘tab’.
Second is “Import Styles” which allows me to copy groups of styles from document to document.
I use these functions in Pages 4.3 on a daily basis.
Does Pages 5.6.2 do either of these functions???
Pages 5 is a gutted version with well over 100 Pages 4 features deleted for the sake of IOS compatibility.


#10

I still have iWorks 09 with Pages 4, but for my usage Pages v5 is adequate…

to keep both took a bit of research, but I wanted to keep the old one, just incase…

john