Not licensed message

I just transferred my classic license for SketchUp Pro 2020 to a new iMac. Since my license was almost up for renewal I renewed it for another year. As I recall (this was a week ago), I re-activated my new installation and license.

I can open a SketchUp file either by double-clicking on the file or from the “open recent” list in the application. I just get the normal warning message about the model being last saved in an older version. I can use Save As to the same filename, which I normally do, with no problems.

This morning I opened a LayOut file by double-clicking on the filename. When I first tried it I got a message saying the SketchUp license was not valid. However, when I double-clicked on the LayOut application in my Applications folder, everything was honky dory and now I can open the LayOut file either via the open app or by simply double-clicking on the filename. I also get the warning about the older version. However, when I try to Save As to the same filename, I get this message
2020-03-21_09-13-47
If it’s complaining about the apostrophe, that boat don’t float because Mike’s Stuff is the same directory where I just did a Save As on the SketchUp file.

Okay, so what am I missing?

That message indicates there’s a problem with the file path. Try getting rid of the apostrophe in your name.

There is also a colon in "Carport:Garage" which would not be allowed on the Windows platform.
It seems I remember a similar topic thread recently on punctuation characters in Mac pathnames.

(EDIT: And I cannot find that topic now. The jist was basically that the Mac does allow some characters that Windows does not, … and perhaps the code that displays the warning dialog is written in a cross-platform sense?)

3 Likes

Mac is able to include \ in file names, and that will then break on Windows. The colon is more likely to be the issue, that’s the standard path delimiter on Mac, and Finder won’t allow it in a file name, so however it was made, it’s going to be a problem.

1 Like

colon

john

1 Like

Guys,
Well now that’s interesting. I didn’t even notice the colon in the error message screen shot I posted. However, there is no colon in the path. Here is a screen shot of the actual folder path
2020-03-22_08-15-24

So where did the colon come from? Does Layout need a colonoscopy?

The Colon was the old path separator on the Mac file system before OS X. You should really avoid having forward slashes or colons in filenames.

McGordon,
The file path in question was created under Mojave and was working fine under Catalina until I got my new iMac and transferred all my files - same path, same OS on old iMac and new iMac. The only difference between the path to the file in question is that on my old iMac my hard drive was partitioned, one partition had all the applications (including SketchUp and Layout) and system files and a second partition had a volume called “Files” where I stored all my working files (e.g. XXXXX.skp, XXXXX.layout, XXXXX.xlsx files, etc.). Now the Files volume is in the same partition as everything else. I did not add slashes, colons or anything else to the path. And yes, the path did contain, and still does contain, an apostrophe in the first level folder name (i.e. Mike’s Stuff) as shown in my initial screen shot. Never had an issue with a apostrophe in a path.

All things being equal, I don’t doubt that the colon is the culprit, but since it isn’t there (see my last screen shot), how am I supposed to get rid of it?

You didn’t put a colon there, but you have a folder named “Carport/Garage” the / is equivalent to a : in the file path and is going to cause confusion. It is getting converted to a colon somewhere as they are equivalent in a file path.

Look at the same folder in the terminal and you’ll see that the forward slash gets converted to a colon. The Finder does let you create folder names containing forward slashes, but it’s a really bad idea!

Screen Shot 2020-03-22 at 18.38.59 Screen Shot 2020-03-22 at 18.39.09
The other way round, creating files and folders names containing a colon in Terminal show up in the Finder with a forward slash.

Screen Shot 2020-03-22 at 18.46.54
Screen Shot 2020-03-22 at 18.47.05

1 Like

McGordon,
Okay but my question is, why is the forward slash being converted (treated) as a colon now? As I said, all things, except for the noted hard drive partition, are the same before [I had the problem] and after [now].

Any colon in an old version of Mac OS would look like a / now. Which could mean that it isn’t a / being converted to a :, it’s a : that looks like a /.

It is strange that SketchUp allows / and \ but not : in file names. Did you try renaming it to not have a /, and see if the error goes away?

Sketchup seems to allow you to save files to a path which includes directory names that have a forward slash in them (which gets converted to a colon). Layout does not let you do so.

The simplest fix is to stop putting these characters in your file or folder names.

I don’t think your issues are related to your new Mac. It’s working the same way here on High Sierra. Maybe you saved the Layout file somewhere else and moved it into that badly named folder in the Finder?

1 Like

To all who have responded and/or view this thread,
I think I figured it out. I created that particular LayOut file last year when I had SketchUp Pro 2019. The path has always been in my Carport/Garage folder. Even though SketchUp Pro 2020 was available, I decided not to upgrade until I got my new iMac. Once I had my new iMac I upgraded to SketchUp Pro 2020 and it was just a few days ago when I decided to open that LayOut file for editing. That’s when I hit the forward slash versus colon snafu in the path. My conclusion is the problem is caused by some change made in the way LayOut 2020 interprets path names.

My solution was to change the folder name to Carport-Garage. I opened the file, did a Save As, Replace and everything worked without a complaint from LayOut.