Not complaining about Make 2017 - but eraser trouble

Does anyone have a fix/workaround for the eraser tool in Make 2017. I start to use it and then after a couple of operations the eraser icon with the little circle switches to an arrow similar to the one for the dimensions tool and occasionally won’t revert to the select arrow after selecting esc or spacebar. I have to then reselect the select tool from the toolbar to continue.

I know Make is not supported and I have no comeback through Trimble but if there is a solution I’d be grateful to receive it.

Many thanks.

Which version of the Mac OS are you using? Long shot: Might try reinstalling SketchUp.

Kind of odd for the tool to change without any user input.

I’ve found that Make 2017 runs but isn’t fully stable under recent versions of macOS, though I haven’t seen the specific problems you describe.

Using Monterey 12.1 and its happening with the move tool too - however it’s only happening when I try to re-hash my models from the warehouse that I downloaded before it went offline for Make. I’ve tried remodelling in a separate window with low poly groups and components and it does it very infrequently - perhaps the brain working SU is tired!

And the cure - as with everything to do with these fantastic computers - a shutdown and reboot, works fine now. Will wait and see if it remains so. Thanks guys.

I found this post:

Looks like it’s the same issue. The topic includes some hidden replies, in which he came back to report that he had not restarted his Mac for a long time, and so tried doing so. The strange cursor changing problem went away after that.

After writing that I see that you got there in the meantime!

Thanks for replying Colin, I appreciate the effort.

While reading your original post I was thinking, reboot.

1 Like