Not all textures created on OBJ export from SKP 2018

(Long time SKP user, first-time posting.) I’m trying to export OBJ from SketchUp 2018. It’s a simple file with 7 materials and 6 textures. All the geometry and all 7 materials export, but only 4 textures. I’ve tried deleting, recreating, reapplying all of my materials every which way I can think of, but SKP continues to misbehave. It’s maddening.

Does anyone have experience with this? Is this a known bug, or are there any workarounds to suggest? Thanks, I’m desperate to find an answer to this one ASAP!

  • You are using the native OBJ exporter (or a plugin)?
  • The materials are applied to faces and not to component instances?
  • How do you measure whether the textures were exported, did you inspect the file content or did you open it in one (or more) other programs (which)? Are you sure it is not an issue with the program that reads the OBJ file?

Old formats like 3DS and OBJ do not store embedded textures so the exported files are put in a folder alongside the model file.

@Anssi: I see the folder where the textures are being stored. The native OBJ exporter is only creating a subset of my textures in that folder.

@Aerilius: thanks for the reply! Yes, using native OBJ exporter, and seeing that not all textures are created in the folder, nor do they show up when importing/viewing in a handful of applications (including 3ds Max and MobiLive). HOWEVER, what’s this about faces vs. component instances? I believe I’m doing a mix, and perhaps there’s something to this? Does SketchUp treat them differently on export? I’ll can experiment here if you think materials need to be applied one face at a time…

When you export a model [xxx] to OBJ format you get three things.
The OBJ geometry data as 'xxx.obj’
The Material data as 'xxx.mtl’
A folder of images ‘xxx’

When you run an OBJ export there is an Options button on the dialog - have you clicked that and checked to export textures etc ?
If not, then only ‘colors’ are included in the MTL file and there will be no image files referenced, or created.

If textured materials are applied to faces OR groups/components then the textures’ images should be saved…


If it's not a simple options issue... A possible reason for flakiness could be the incorrect installation of SketchUp, on a PC ! The [only] correct way to install/reinstall SketchUp is as follows... Close SketchUp. Find the installer exe file [probably in your Downloads folder ?] Select its icon. Right-click > Context-menu "Run as administrator"

When prompted choose “Repair”.

Restart SketchUp and retry…

If it hasn’t improved, repeat the above process [using “Run as administrator”], but this time “Uninstall”, then immediately “Install”…

Either process should not adversely affect any User Plugins etc…

Installing any application in any other way can result in all kinds of unpredictable problems - sometimes of unexpectedly subtlety and weirdness - Just using ‘Run’ or double-clicking on and installer’s exe file is NOT the same thing - even if your have ‘admin-powers’ !

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.