Not able to log in Google Workspace with Edu Sketchup

Hi, I have added Sketchup for Schools app to our Google Workspace admin account however when pupils or staff login, we are still getting this error:

Authorisation Error
Error 400: admin_policy_enforced
Access to your account data is restricted by policies within your organisation. Please contact the administrator for for more information.
Request Details
The content in this section has been provided by the app developer. This content has not been reviewed or verified by Google.
If you’re the app developer, make sure that these request details comply with Google policies.
response_type: permission id_token
This redicilous site will not allow me to post all of the error as a new user is not allowed to post URLs - really not helpful.

I have also verified that Google Workspace Marketplace has SketchUp for Schools listed and On for everyone, but still we get this error. Please advise.

Still, I cannot post the error?
Trying an image this time, why is this so difficult?

Sketchup is clearly added here in Workspace admin, but still users get the error message I have tried pasting above.

Does anyone have any advice on what to do please? I have no way to contact support as this is the free version, it is a shame as we would love to use this at our school, but if we can’t get any answers, we will look at some alternative apps.

Hi all, I am so disappointed that nobody is able to help. As a school, we were really looking forward to using Sketchup, but it appears the tech support is non-existent for ‘free’ product variant users. Very disappointing and doesn’t offer any incentive for us to try and eventually upgrade if we are unable to get any assistance on how to get the free version to work.

Just a user fellow Google Admin here (not associated with SketchUp). Under Apps > Google Workspace Marketplace Apps > Settings, do you have it set to “Allow users to install and run any app from the Marketplace” or to “Allow users to install and run only selected apps from the Marketplace”. If the latter, make sure SketchUp is in the whitelist of apps?

A web search of the “Error 400: admin_policy_enforced” error you’re getting is mainly showing articles advising people to just remove the app from your domain and re-add it.

@Steve_Ketchup or @Tori_SU is this something either of you can help with?

Thank you so much for your reply. Really helpful of you to post.

I had added the following in the white list:

I did not have the top line which was the Android app. I added that in and now it works.

Thanks again for your help with this, I really appreciate it and so will our children! :slightly_smiling_face: :+1:t2: