Not a solid - short edges

I created a corrugated metal profile, made a 1 mm offset, connected ends with two short lines, pulled it to 100 cm and made it a group. Tested with Solid Inspector and it says “Short edges”. The short edges are 1 mm. Is that too short?

1mm shouldn’t be too short on its own. Upload the SKP file so we can take a look and see what really is the issue.

The short edges are 1 mm. Is that too short?

Less than 0.0254mm would be though. (less than 0.01inch)

Here’s the file.

Plåt_korrugerad.skp (175.7 KB)

I just opened your file and selected the group. SketchUp and Solid Inspector 2 both report it as solid. I didn’t do anything to it.

I exited SU, started it again and opened the file. Same thing. Could it have something to do with the settings in Model Info?

No. I don’t think so. I wonder if there had been a short segment that was cleaned up when you exited out of the model. Or maybe you just weren’t holding your tongue right. :smiley:

See if you get the issue with this file.
Plåt_korrugeradBox.skp (79.6 KB)

Just thought I’d throw in here. I see this same behavior as the OP , particularly when doing complex shapes with the Follow Me tool ( even when using “The Dave Method” ). Solid Inspector will show hundreds of short edges but entity info panel shows the object as solid… go figure. Bad me I just tend to ignore it and move on…

Same erros with this file.

Hmmm, very odd, Dave and I have no problem with your file and my uploaded one was purged and cleaned up but you still have issues. Can’t say I have every seen a short edges problem within Solid inspector, whereas you and Tuna see it, so I think there is something in your systems that is similar.

That might be the settings in window->Preferences->General
Always fix my models
Check my models…

I have that setting turned off because it too often breaks models when fixing them.


I keep it turned off, too.

1 Like

Have “Always Fix Models” unchecked. It seems it breaks more than it fixes. The " short edge" behavior doesn’t seem to have a predictable behavior for me, don’t always see it. I’ve been able to “fix it” a few times by running VertexTools Merge Close Vertices function.Always thought it was maybe a weird “Mac” thing but the OP is on Win10 so who knows?

1 Like

I too keep it of, it often helps opening files that other’s can not open or having difficulties opening with.
The CleanUp3 from @thomthom tis having severe time delays when turned on, too.

I created a simpler model. When thickness is 3mm it’s OK but at 2mm I get the same error again Weird!.

Even simpler.
2mm thick


3mm thick

Care to share that file?

Actually I just realised that while you have solid inspector up, you can right click and turn on/off “detect short edges”. It’s new one to me. My theory is that you have “detect short edges” set “on” and the threshold you have set is above 2mm so solid inspector is just reporting what it is set to do.

You could either set the threshold to lower than required or simply just turn it off. It appears to be off by default.


I’ll bet that’s exactly whats going on there. And thank you IanT. Because I was not aware of that right click menu.

1 Like