Solid Inspector--how to fix short edges

I want to modify a 3d SU model from Thingiverse, then get it 3d printed.

I’ve never done any 3d printing, but I figured I needed to make sure the object to be modified was a solid.

I used the clean-up extension which fixed some things. I also had to close a small open face manually. But, I can’t fix the 313 short edges Solid Inspector is complaining about.

I saw a thread that suggesting scaling the model by 1000x. The info button associated with the errors also suggest scaling the model

If I scale the model by 1000x, the short edge complaint goes away. But, they just come back when I scale it back down again.

So, I’m missing something. Is there something I should do when them model is scaled 1000x so it’s still a solid when I shrink it back?

Why scale it down again. The .stl file you’ll export from SketchUp will be unitless as are all .stl files. Just tell the slicer software what the import units are (inches or mm) and it should all be good.

I would import the .stl into SketchUp with the import units set to meters and avoid problems with short edges from the beginning. Run CleanUp3 to get rid of unneeded coplanar edges before you start modifying it.

1 Like

@DaveR I’m not at my computer, but I remember short edges being a setting in Solid Inspector that is usually off by default. The tolerance of the short edges can be modified in the setting too. It isn’t necessarily an indication that the object isn’t solid.

1 Like

Yes. I know that short edges aren’t an indication of solid or not solid but if Solid Inspector is identifying them, they could cause problems in maintaining the solid as modifications are being done.

Didn’t realize that everything would be unit less anyway. Now it makes sense.

Thanks.