Solid Inspector short edges

I have a ton of short edges that I dont know how to correct. I dont understand why they keep happening and would love advice on how to prevent them in the future.
Akiraclass5.1.skp (453.4 KB)

I’m not getting a message about short edges but maybe I haven’t run Solid Inspector on the right object. Very likely you are getting the message due to the way you are creating the geometry and because you have Length Snapping enabled. From what I see in your model it looks like you are using a sort of scattergun modeling work flow which is also likely impacting the creation of short edges.

On it’s own the short edges message doesn’t mean there’s a problem with yur model. It’s more a warning that you could potentially have problems as you continue modeling.

“Scattergun modeling work flow” that does not sound like a compliment. Im fairly new at sketchup so Im sure it looks like a mess to a more experienced user. You should have seen version 1.0

I didn’t mean it as an insult.

Fair enough. I have run into less friendly help and was on guard. My bad. I am grouping as I go and using solid inspector but what is “length snapping?” and is it something I should have turned off?

Preferences > Units setting
Length Snapping
Almost always best ‘off’

I turned on endpoints in the style, and I too don’t see any unreasonably short edges. Can you show us an image of where in your model you believe there are short edges? One thing I did notice is that two surfaces that you may have meant to be flat are not planar. As a result their smoothed surfaces are triangulated (turn on view->hidden geometry to see the triangles), which requires endpoints along the boundary:

You have four instances(copies) of Heather in the model and you have the short edge setting set to 3mm so it is going to pick them up. As mentioned above, short edges is more of a warning of possible future issues, it doesn’t stop things being a solid.

You can turn off short edge detection and adjust its threshold by right clicking on the model while solid inspector is active.


today I learned something…

thanks box !


These all seem to be short edges and I dont know how to resolve them without fundamentally altering my model. As for the non planar shape that part of the model curves up from left to right. Will that be an issue moving forward?

Have you tried changing the threshold, or simply turning off short edge detection.
GIF 14-04-2024 11-38-30 PM

1 Like