No way to update a subscription from SU Pro 2022 to SU Pro 2023

I’ve google for over an hour and read the forums and there isn’t a way to upgrade my subscription from SU Pro 2022 to SU Pro 2023. All the directions I found have no corresponding menu options on my version—advice here in the forum talks about extensions but not the application itself. I’m pretty frustrated at this point and hoping for a clear concise answer or pointer to directions. Thank you!

um, you update your license and install the 2023 product. they install into different directories and separate (mostly) registry entries as well. if you have extensions, materials, and components in 2022, either copy them over the 2023 directories or set up your preferences to point to them.

You go to your products page at

and download/install SketchUp 2023

A subscription covers you to use 2021/2022/2023 , you’ll find them all there

Thanks. I tried using the new version (2023), but it says I’ve exceeded my activations even though I’ve deauthorized my machines three times. Does it require some time for the deauthorization to take effect?

It should happen immediately - if it isn’t trying delete the login_session.dat file

SketchUp Pro 2022 - Unable to Launch Browser to Log In (

Do it for the 2023 version/folders

Hi. Thanks for the information. I tried that but the directory referenced under Library/ApplicationSupport/Sketchup doesn’t exist on my machine (I have hidden directories and files turned off). I also did a system-wide search for the “login_session.dat” with no luck. I still can’t get past the “You have exceeded your allowed activation” screen despite having deactivated them six times from two different computers (in case of browser cash issues). It’s been a hour since my first deactivation. I’ve cleaned out my browser’s cache and rebooted my Mac.

At this point, I’ve put off working on my project for too long and need to get back to being productive. I need assistance so I can get back to work. Thank you!

One more thing. Despite having deactivated my machines six times, I just discovered that I can still launch SU 2022 without a hickup, which means (as far as I know) that the deactivation isn’t working at all. At least now I can get back to work. I was hoping to use the newer version of the software but it seems, at least for now, it not going to happen. I was really looking for the using the new “Snap” feature.

Most likely you are looking in the wrong folder. Copy & paste this one into Finder->Go->Go to Folder. ~/Library (traditional shorthand for /Users/yourid/Library) is different from the system-level /Library. Also, the spaces in the path are required but missing from what you typed.

~/Library/Application Support/SketchUp 2023

Change 2023 to 2022 for that version’s folder.

That did it! Thank you so much!