Tool bar disappear on Sketchup2023

Just un-installed and re-installed newest version. Still no tool bars.

I will update. I have a
Razer Blade 15" Laptop -
Windows 11 - 10.0.22621 Build 22621
Sketchup Version 23.1.319
NVIDIA GeForce RTX 2080 with MaxQ Design
Intel(R) UHD Graphics 630

Updated Info. Thanks’ Dave R

1 Like

Uninstalling and reinstalling the program doesn’t touch the file that stores the locations of the toolbars. The ALT+SpaceBar thing is for the various windows if they are loose on the screen; Model Info, Preferences, etc.; not the toolbars.

Since you’ve tried other things and they didn’t work for you, first, close SketchUp. Then go to User/AppData/Local/SketchUp/SketchUp 2023/SketchUp and rename the file called PrivatePreferences.json to something like OLDPrivatePreferences.json. Then find the installer, probably in your Downloads folder, right click on it. Choose Run as Administrator from the right click menu. If asked, choose Repair. After that, open SketchUp. You should be able to enable the Large Tool Set and have it appear on your screen.

Note that renaming or deleting PrivatePreferences has effect on all of your toolbars so you’ll need to rearrange them but it will reset the location for the Large Tool Set. After you’ve arranged the toolbars work on a model file a little or make a new one and save it to ensure the new PrivatePreferences file gets updated.

Thanks DaveR. I just followed those instructions and it said I have too many instances of Sketchup and when I clicked the Manage Subscription Button it tool me here.

Go to connect.trimble.com, sign in to your account. Go to My Trimble Subscriptions.
Screenshot - 10_7_2023 , 8_20_39 PM
Click on View included Applications.


Under SketchUp Pro click on Manage Devices. Then Deauthorize All in the window that pops up. Then try opening and signing into SketchUp.

@colin might be able to tell you more about your subscription when he gets in to work tomorrow.

I am totally locked out. I have no other instances of sketch up running.
I followed your above note. Still brings me to this window.

I was hoping to get some work done. I am totally locked out.

Did you go to connect.trimble.com?

Did you try clicking on Manage Activations in that window?

In that window, click on the profile at the top right and sign out, then back in.
The manage devices button sets the number of signed in session to zero, but one needs to sign out and back in to recognize the changes locally.

Another thing that might help in such cases is to change the default browser in Windows and proceed the sign out/in.

Either the first solution (that Dave already explained), or the second in this thread that consist of deleting a file to force your PC to recheck the licence

at times windows has troubles understanding that you logged off. you can help by deleting the right file (second link)

This worked. I am back into Sketchup. What a work around just to get my tool bar back. Thank you for everyone’s input.

Yes. I needed to follow MikeW post and that got me back in. Toolbars working. Do I have to do this every time I forget to drag Sketchup and my tool bar to my Laptop screen and save it from my main monitor

Why not ‘dock’ the large toolset on the left side?

Another option might be to set the the main screen in Windows to the other monitor (or vice versa) in the screen settings (rightclick on an empty space on the desktop)

There are a lot of different scenarios possible, maybe one uses a dock at the office, and then connect via hdmi back home, all with different monitors etc.

You shouldn’t need to but I would suggest you leave toolbars docked at the edges of the Model window. Then you won’t have any issues. It’ll also save you time when modeling because you won’t have to move the cursor so far to get tools off the toolbar.

Got it. I am very active with moving my tool bar around while I work. Usually it sits to the left on top of the sketch up window.

Why do you move the toolbar around so much? Seems like that makes you search more for tools than you should need to because you can’t build any muscle memory. It’s why my lovely bride is always searching for her phone and car key. She never puts them in the same place twice.

FWIW, here’s a screen grab of my toolbar set up. I replaced the Large Tool Set with two custom bars on the left. I also combined tools off of several toolbars at the top to preserve screen real estate. I omitted tools I don’t use in my normal workflow such as Dimensions, Text, and 3D Text. I normally use keyboard shortcuts for many of those native tools but when I am doing online instruction with students or recording videos I will show using those tools off the toolbar, too. The tools are always in the same place and they’ve been in the same place since the option to create custom toolbars was introduced in SU 2016 (if I remember right). The toolbars have never gone AWOL either.

1 Like

That is cool but way too distracting for me. I like it simple and I like to put the tool bar next to what I am working on. The tool button is right there ready to go.

I am back set up with my extra monitor and laptop. The Large Toolbar is nowhere to be found.
THis is crazy. I tried resetting the workspace and running the new version download installer to reinstall. It didn’t give me an option to repair as administrator. PLease help.

If you were installing the latest release for the first time there’d be no Repair option. Did you right click on the installer and chooose Run as administrator? If not, do that and this time choose the Repair option.

You could delete PrivatePreferences.json from User/AppData/Local/SketchUp/SketchUp 2023/SketchUp and restart SketchUp.

I did just do that. Still no tool bar. I’ll have toi try the last direction you gave. Thanks.