No Select Cursor -- How do i turn the pointer on?

I just re-installed sketchup pro on a clean install of win10. same computer, but i was having performance problems. computer runs better, now. when I open SU, there is no Select Tool Cursor. I can the rotate and rectangle icons, but there is no cursor. so, when Select is selected, i can’t see where i’m selecting. I can still click on stuff with my invisible select cursor, and when I hover outside of SU my cursor reappears. I’ve uninstalled, restarted and reinstalled sketchup twice. still no cursor. vectorworks and adobe stuff are fine. just sketchup.

how do i turn the cursor icon on in sketchup?

thx

Sounds like a Graphic card issue. Did you update the Nvidia driver when you reinstalled the OS?
Also did you install SU by using the Right Click on the Installer file and select Run as Administrator method?

Yes.
No. I’ll try that.

didn’t work. I can’t find mention of this problem anywhere. Is this unheard of?

An invisible cursor is rare but not unheard of. It is generally a graphic issue. Try going to Window/Preferences /Opengl and untick use fast feedback.
If this works it shows there is some problem with your graphic card setup.

didn’t work. I changed my graphics card to force sketchup to use the integrated intel graphics processor. intel gave me a cursor. I closed SU, and tried using nvidea again, and cursor gone. I switched back to intel, and the cursor is gone. I had it for a second.

I guess I can just use the touch screen, but I can see that get pretty frustrating after a while.

Almost all NVIDIA cards will work better than an Intel one, so something is amiss.
If you briefly got a cursor, then something must be fixable.

With fast-feedback off in OpenGL prefs, does anything change with either card ?

In the NVIDIA Control Panel is SketchUp set up to choose its own settings ?
Something is clearly adrift - it should be fixable…

Sometimes, if you have more then one monitor, things go haywire.
Do you have more then one?
What scaling do you use?

i reinstalled the drivers for nvidea, and that didn’t work. i opened up nvidea experience, and checked for updates just in case. i was presented with the option to update the gaming drivers i had, or update to the “studio” version. same number but one is called “gaming” and one "studio."i tried that and it worked! then i tested other apps, and everything looked good, so i restarted just to verify, and it’s broken again. i’ve sent this to trimbal and linked this thread.

thx for all the suggestions. keep 'em coming if you have 'em.

to answer some questions above: i do not have 2 monitors set up yet. i was using 250%, but i scaled down to 200%. sketchup and layout were set to either intel or nvidea manually, and i was switching them manually.

here is new sys info:
NVIDIA System Information report created on: 09/01/2019 10:16:40
System name: DESKTOP-FP960F1

[Display]
Operating System: Windows 10 Home, 64-bit
DirectX version: 12.0
GPU processor: GeForce GTX 1050
Driver version: 431.70
Driver Type: Standard
Direct3D API version: 12
Direct3D feature level: 12_1
CUDA Cores: 640
Core clock: 1354 MHz
Memory data rate: 7.01 Gbps
Memory interface: 128-bit
Memory bandwidth: 112.13 GB/s
Total available graphics memory: 12195 MB
Dedicated video memory: 4096 MB GDDR5
System video memory: 0 MB
Shared system memory: 8099 MB
Video BIOS version: 86.07.63.00.0C
IRQ: Not used
Bus: PCI Express x4 Gen3
Device Id: 10DE 1C8D 39AB17AA
Part Number: 2904 0001

[Components]

nvui.dll 8.17.14.3170 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.14.3170 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.14.3170 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.14.3170 NVIDIA User Experience Driver Component
nvCplUIR.dll 8.1.940.0 NVIDIA Control Panel
nvCplUI.exe 8.1.940.0 NVIDIA Control Panel
nvWSSR.dll 26.21.14.3170 NVIDIA Workstation Server
nvWSS.dll 26.21.14.3170 NVIDIA Workstation Server
nvViTvSR.dll 26.21.14.3170 NVIDIA Video Server
nvViTvS.dll 26.21.14.3170 NVIDIA Video Server
nvDispSR.dll 26.21.14.3170 NVIDIA Display Server
NVMCTRAY.DLL 26.21.14.3170 NVIDIA Media Center Library
nvDispS.dll 26.21.14.3170 NVIDIA Display Server
nvDevToolS.dll 26.21.14.3170 NVIDIA 3D Settings Server
PhysX 09.19.0218 NVIDIA PhysX
NVCUDA.DLL 26.21.14.3170 NVIDIA CUDA 10.1.120 driver
nvGameSR.dll 26.21.14.3170 NVIDIA 3D Settings Server
nvGameS.dll 26.21.14.3170 NVIDIA 3D Settings Server

Try setting the scaling to 150%.