No RDP Support - OK - but don't make it a hassle

This thing where sketchup checks for your hardware acceleration upon startup is a serious hassle for our work. I understand how you would not want to support it, but actively preventing it from running in a virtual environment seems unnecessary.

I can see how this might be a violation of the license terms if I was operating a headless server whereby I was creating in effect essentially a floating network license that could be used by multiple users.

But that is not the use case I am describing. What I would like to be able to do, is operate my own physical desktop workstation, upon which my license resides, from a remote location such as my home, or my laptop in the field, where another license also resides.

The computers I would be using to log into my office workstation from also have Sketchup pro licenses installed on them. Depending upon the particulars of the case, I might choose to run sketchup by pulling the files across our VPN while running sketchup locally, or I might rather use RDP to access my office workstation to access the file. A number of factors come to bear on this choice: model size and complexity, referenced files locations, the need for others in the office to read the file as I edit it, availability of plugin licenses, specifications of the internet connection used, etc.; In any case performance is degraded, and I would not expect it to be supported. The point is that I need to get my work done and performance is not always the primary driver. Preventing me from using it that way in the pro version is silly.

Sketchup is a tool. It is a very good tool. It should remain the flexible tool it has been. Barriers to the efficient application of this design tool in the Pro version are unwelcome developments.

Yes, I can try to remember to start sketchup before I leave the office (avoiding the card-check) or I can log into my desktop using a remote protocol that somehow avoids the card-check (such as NoMachine), and start or restart Sketchup that way. Then I usually go back to RDP because performance is better. It’s just a hassle to force us to go through such workarounds. None of our other 3D software behaves this way.

SketchUp can be run remotely, if the RDP software supports OpenGL. Some do. It has been discussed before, what I seem to remember that the standard Windows RDP won’t work bu that there are others. I once tried a Citrix/Nvidia based virtual machine and that worked perfectly too, even when logged in by connecting my laptop via a 3G phone.

you might want try if the Parallels RDP Client does support OGL.

Not adhering to the system requirements and/or license agremeent doesn’ rectify to claim issues arising then. [imho]

I appreciate the suggestions. I will look into Parallels. My point above is not that I expect support from Trimble to run the software in this manner, but that outright preventing it from starting normally under these conditions is like a poke in the eye for paid professional users. Parallels may solve this problem, but it also comes at an additional cost when all I would like to do is access my software in a pinch during off hours and to check something when I’m on the road - without complication. Trimble could do what Autodesk Navisworks does for example: gives me a polite warning that my performance will be degraded, and then allows me to continue. How difficult is that for Trimble to achieve. I think this is a poor design choice - one that I hope they will see clear to change soon.

[afaik] the pure RDP Client w/o the Server is free.

A command line switch to disable the hardware diagnosis of the SU launch process might be a nice option for ‘power users’ knowing what they are doing.

You can use RDP for Sketchup, it just needs to be already running on the target computer when you connect to it.
You can either run it, and immediately disconnect, then reconnect after 10 seconds or so when Sketchup starts up, OR you can create batch file, that starts sketchup with delay (you have to be disconnected when sketchup.exe is executed), the command needed for .bat or .cmd file is Timeout /t [number of secs].

Simple solution…

Go to Task Manager on the Remote Machine and check your RDP ID in the “Users” tab, in my case it was “2”.

Then open notepad, and write the following (assuming your ID is 2, change the number after tscon to suite)…

tscon 2 /dest:console
cd C:\Program Files\SketchUp\SketchUp 2017
sketchup.exe

Select the file type as “All Files” and then enter the filename as Sketchup Launcher.bat and save to your desktop.

When you login to RDP, click on the shortcut. It will disconnect you from RDP and open up Sketchup in the local console. Wait a few seconds and re-connect your RDP - Sketchup will be open.

There are more elegant .bat code solutions available now online here…

https://forums.sketchup.com/t/sketchup-can-not-run-through-window-rdp/100389/9

https://social.technet.microsoft.com/Forums/windowsserver/en-US/c8295ef8-3711-4576-9293-2c4965280165/opengl-and-remote-desktop?forum=winserverTS

1 Like