No Options selections available but the Attributes are there..? LOST

bug

#1

Hello I am only into the basics of DC Components but this is something that should be simple. Why would you get Attributes Options when you highlight a DC component but the Options dialog box fails to offer any selections THAT are suppose to be their. I have a screen shot of the options that are displayed and changed in his video. I imported his provided DC door, I can scale it and open and close it. Also change the degree of revolution but even though the DC is selected. It only shows an empty Options Box but it has user options available.

I am experiencing this in SU 2017 and 2016 Pro and DC Components are up to date. If I restart SU it loads and both functions work, if I change a few of the option settings. Then try to re-select them it shows nothing again, So I have to close the file and re-open it to change the options back…LOST!!


#2

Could you either upload a copy of the DC, or provide a link from which to download it?

I can’t find it on the sketchthis.net site.


#3

Hello John and thanks for reply. From inside S-UP clicking the 3D Warehouse icon from the toolbar. I typed in Dynamic Door / Eric it is one of the 5 or 6 listed. He himself did a 2014 Base camp presentation on DC’s and this is his door that follows along with his tutorial from here: https://www.youtube.com/watch?v=OBdM216Z4U4

I loaded into my model and all is fine both Attributes and Options are there. If you change the options to bevel then to rounded. Or change a few other options and close it. It is when you re-open it that the Options dialog goes blank but the Attributes are still there??
Now nothing seams to get it to work but it did at one time…

Dynamic Door.skp (345.3 KB)

I first opened the tray that I have the components browser in and typed Dynamic Door / Eric to get a copy. I also used the 3D Warehouse icon and did the same thing and downloaded into the model. I downloaded it to the Desktop and tried to import and open. It is hit and miss BUT I was changing the Options earlier now they don’t display. This is why I walked away from these a year or so back, or I have no luck and a cloud over my head. Are they really this much or a pain in the A88!!


#4

If you drill into it from the Outliner you can see how much hidden items are nested in it. Just a very frustrating // beginning to learn something and have no experience with them to boot.


#5

I just closed S-UP, re-opened from the components browser typed in Dynamic Door / Eric loaded it directly into the model. I highlight it and both options are available to select and change. Where as a minute ago the Attributes only had information to select. ???


#6

DCs are a bit temperamental at the best of times, but they CAN work and work well.

Do you want this one to work in a larger model you are making, or use it as a model to learn how to make your own?

Will try to download the model in next hour or so, try it, and get back to you later tonight.


#7

I have been following the Skill Builder Basic on DC’s plus reading what I can in the Knowledge Center documentation. Dan Rathbun offered these in a thread to a nother poster and I bookmarked them for addition help.

I am hoping to be able to create my own and Ruby scripts in time. The DC’s are my first challenge and looking at You Tube videos to bring life to the documentation. I know it will take sometime but I want to learn them completely, even though they confuse the hell out of me!!
Having to open a clean file to continue following his video just took the momentum out of it. If you know what I mean. I am stubborn and will keep chipping at it. Anything you can provide would be a great help and being it worked and then stopped. That is what was frustrating me. I WILL FIGURE THESE OUT!! and I thank you for your time and help. In what ever you can provide. Something that did work and I could save a copy of. Then work backward with it / reverse engineer as I learn from the material is how I retain this stuff. Would be a great help… Following DaveR from his blog site Design.Click.Build was how I became proficient with S-UP. It was not what he was building, but seeing the tools applied and manipulated. Gave you something to go on. Yes you created a table leg or a draw pull. But opening up your minds eye on how to proceed forward or get around the hurdle if you did not have the strength yet to jump over it. Thanks again and …Peace…


#8

I first downloaded the file from your uploaded link and file in post #3 above, and used File/Open open to get it into a new drawing.

When I R-clicked on it, and selected Dynamic Components, I got a blank Options window. Double click on the component to open for editing, and R-click on the centre of the door, and I get a non-blank Options window, but with only width and height options for the Raised Panel. So something definitely wrong there versus one’s initial expectations.

I next tried a direct download from the 3D warehouse, into a new drawing.

The component works as expected, open/closes with the Interact tool, and after saving, closing the SU window, and re-opening it directly by double clicking on the file, it again works properly on opening - I get the full range of options shown in your screen shots.

Opened an old drawing, Imported the component, R-click, and again no options. BUT this time, I had to explode the component once to remove the ‘outer’ component wrapper, and the Options all appear.

Change a few options, close the DC Options window, and reopen it - no problem, the options still all visible.

I wonder if you never removed the ‘outer wrapper’? If so, you would get the options if you first double clicked on the ‘wrapper’ component to get at the DC wrapped inside, then get the options when you R-click and select DC/Options.

If you then closed the component (completely) and closed the Options window, then R-click again having selected the component, and re-open the DC/Options window, you will get a blank options window.

I can’t get it to ‘misbehave’ as you describe.

Could it be as simple as you not have exploded the component after import? If it DOES import without a wrapper, this will wreck the Options. But if it HAS the wrapper component, then you need to explode it to get the Options to appear.

I know this baffled me the first few times I tried to use a pre-built DC, and also when I first saved one of my own. File Save As with the component selected, gives a different result from what you get when just saving the whole file.

The component you saved and uploaded definitely DOESN’T have the options you expect when you use File/Open. It looks as if it has been exploded once, and then wrapped in a blank component, not the original DC (it hasn’t been, but it has lost the link to its Options).

You MUST use File/Import to include the DC in a new model. If you just File/Open it, you lose the DC wrapper level.

Confused? So am I, a little. But the simple rule seems to be: IMPORT a DC to use it in a new or existing model, don’t Open it. If when you import it, you get an extra ‘wrapper’, explode it once, THEN you should get the options.

I haven’t found this explained clearly in tutorials or Help files - it probably is there somewhere, but it doesn’t seem obvious where, if I search for ‘Sketchup Dynamic Components Help’ or similar.


#9

Thanks for the time and the explanation. IT IS BOOKMARKED and I know I will need to go over it many times. I just need to keep working at them. SLOWLY, as I do get over zealous and jump into the deep end. Your explanation is comparable to other software I am also learning on top of this.
I have some other experience with Blender and Oxygen2 used with Real Engine for game design. Importing 3D’s files or Collada files carries meta data that is required to insert the object into the model, but just opening them it rejects them every time. The error dialog is missing KFD data or " something not found in path" As configuration data or specifics needed to complete the file path are lost or as if you spelled it wrong.
I do know I have my work cut out for me and appreciate the help, back at it!!! Thanks again and …Peace…


#10

I have this issue on a MAC. The components options dialog simply says: ‘No components selected’ while the Attributes dialog has the information.


I have had this for some time now, but can’t detect a specific reason or reproducible workflow. However, my workaround is this: go to the extension manager, disable DC, quit SketchUp and then restart SU and enable the DC extension again. Now: component option show up ,again!

@DanRathbun Since I thought it had to do with my personal (Mac) setup and was not encountering this issue on the Windows bootcamp SU-version, I figured it was not a SketchUp-bug. Turns out the OP is on Windows and has encountered the same issue.


#11

It can be a hint to a DC error


#12

I recommend you use “Parent” in lieu of “Frame Rounded Edge” etc, you will find most will change after the first component edit, as I believe you use copies to create the others


#13

But does this solve the issue that the DC-dialog Component Options doesn’t seem to notice that there is something selected at all ?
Once I have encountered it, the only work-around for me (on Mac) is to unload DC via the extension manager, apply changes, quit SketchUp, start SketchUp again and then enable DC again. Have tried dozens of different Components, but I can’t predict this behavior. So , something must alter the initial settings in the DC-extensions, and along the way it gets messed up.


#14

I have had issue with the disappearing option box too, switching on and off is a traditional work around, However I have noticed that sometimes it is a result of an DC error, It is hard to pin point the trigger. I was surprised that you were able to get “Chris” to show the same, was there any other trigger before from another DC?


#15

Indeed I think it has something to do with the Thumbnail generator…:


#16

So Chris adopts the house, this seems to be an apple thing, they remain separate in Windows.


#17

This topic was automatically closed after 91 days. New replies are no longer allowed.