Component Options is Blank

Using SU2020, a file which has worked today, in SU2020, suddenly quit showing the info in the Component Options panel and reports “No Component Selected” although one is clearly selected and the Attributes panel shows all of the relevant formulas, data, etc.

I have closed SU and re-opened it to no avail. I have opened other working SU files with DC’s also to no avail.

Help.

I have this problem in SU 2018 Pro on Windows 10. Below is the sequence I have found to get around this issue. I previously posted this on Sketchucation and is the text for the two posts I made.

Original post:

I have come up against an issue regarding the DC options panel. Clicking on a component will display it’s attributes in the DC attribute panel but the Options panel indicates that no component has been selected. Searching online has shown that this behaviour has been seen before but I could not find a definitive solution.

To date I have tried the following:

Uninstalled the DC plugin and installed the latest version from the Extension Warehouse.
Ran the Sketchup ‘Checkup’ app to make sure my system is adequate.
Checked that my graphics card driver is up to date.
Downloaded the latest SU Installer and ran the repair option (Run as Administrator).
Disabled all my installed plugins in the Extension Manager and restarted SU.
Uninstalled SU and then installed afresh. (Run as Administrator)

Occasionally, in a new unsaved model, I can create a DCs both with and without user options and both panels will populate. However, on saving the Options panel reverts to not seeing a selected DC.

The Ruby Console returns the following when selecting a DC:

Error: #<NoMethodError: undefined method deleted?' for #<Sketchup::Model:0x0001efeaf23df8>> c:/users/brian/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcclass_overlays.rbe:212:in block in pull_attribute_tree’
c:/users/brian/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcclass_overlays.rbe:212:in delete_if' c:/users/brian/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcclass_overlays.rbe:212:in pull_attribute_tree’
c:/users/brian/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcclass_v1.rbe:245:in block in show_dialog' SketchUp:1:in call’

Any ideas on fixing this would be greatly appreciated!

SU 2018 PRO, Windows 10

Second post:

After yet another go at this I found the following. The Component Options and Component Attributes panels can be opened at any point in a modelling session including after selecting/deselecting existing components (not necessarily dynamic components) or creating new components. However, the Options panel must be opened first. Any component selected will now show up in the Options panel. Before the Attributes panel can be launched a component (any) must be selected. Once the Attribute panel is launched the selected component can be deselected without any inputs to either panel. Thereafter, components can be selected, attributes added etc. Both panels will work as expected. Both panels can be dismissed if not needed further but to relaunch them the same sequence must be observed.

Maybe this behaviour is a quirk of just my own setup but the procedure that I found (stumbled across) is certainly not in any way an explanation.

Well, I tried this - opening the file freshly, opened the Options first, then selected the DC.

It didn’t work.

Did you restart SketchUp? The DC extension needs to be reloaded. The best way to open the panels is by rightclicking on a component and choose from the context menu.
Do not use the toolbar icons.

I could’ve sworn that I re-started SU yesterday; I know I re-loaded the file and other DC files during my troubleshooting process. However, this morning I definitely re-loaded SU, and all seems to be working fine. I did also follow your suggestion of using right-click context menu rather that the Toolbar icons ( that issue seems a bit curious). The Toolbar icons do allow me to get to the Interact icon for on-click controls.

Thanks for your help. I’m glad it is working again and am ready for Aaron’s next session on DCs.