Attribute options window remains blank


#1

I have a dynamic component with several options that a user can select from but when I open the options window it remains blank.


DynamicDoorwithFrame.skp (99.8 KB)


#2

Your options are not in the top level component. If you open the top level component for editing and then select the Door-Frame-Trim component, you’ll see the options.


#3

It doesn’t matter which sub component I select I still get no options appearing in the options window


At least I believe I have the correct subcomponent selected in this screenshot.


#4

From the number of posts you are making on DCs, you are obviously trying hard! I have too and know how frustrating it can be.

I am attaching a short gif showing what I see when I open your file in SU 2018.

The first thing to notice i that if I click on your component, I DO get a list of attributes. So, at that point, everything looks fine. However, I seem to remember encountering just your problem myself in the past. Does it still happen if you close SU and re-open it?

Then I tried changing one of the parameters you set up. It made no difference. I think this may be because this is a work in progress and you have not yet set up the formulae that dictate how geometry gets changed by user input.

Then I took a look at your nesting. You have sub-components. I have never managed to get sub-components to work in DCs. I believe they should but in practice I have not been clever enough to make them act in a predictable manner. For a simple component like a door, I suggest you eliminate sub-components.

Hope that helps.

BTW, are you both @zipster1967 and @trentjperez? Or do you have a twin??


#5

In DC, it is called Copy😂


#6

I am both but I can’t seem to login to the @trentjperez account and don’t even know what email address it’s associated with.


#7

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.