Dynamic Component Options Panel Not working

Working with a one day old install of SKU 2020. Started a new Dynamic Component and none of the options are showing up on the “Options” panel. Have saved and closed and restart SKU with no change. Just wondering if anyone knows if there is a bug with the DC Options panel.

How did you open the panel? With the toolbar?
It is best to open the panels by rightclicking on a component and then choose Dynamic Components->Panel of your choise
Try closing and restarting

Tried that one…no change.

Thanks!

Then, disable the extension in Window->Extension Manager, do a save, close SketchUp.
Start again and enable the DC extension again.
Do not use the toolbar icons.

No…have a second monitor, but it is still attached and working.

Open outliner and check the level of nesting, maybe there aren’t any options…

I now see that the panel is showing, but isn’t showing any options. Then my comment doesn’t make any sense.

One thing is the lowercase “u” bug. DCs don’t work if the model filename or a folder name in its path starts with a lowercase “u”

Whaaat? That is… special

1 Like

No problem my friend…

Well at least I’m not fighting that one. Thanks!

That was the culprit.
Followed your instruction here and now have options on the option panel.

Is there a fix for this known issue coming down the road? Prefer the icons for sure.

The order is important if you wanna use the icons. I never remember what to click, first, though. My guess is to open the attributes panel, first 50/50 chance :slight_smile:

Probably just going to use the menu’s…less frustration in the long run I guess.

Hello everyone,

Not an expert in Sketchup but with few skill. Have a pro version 2020/W10/NvidiaRTX5000-16Go on a P53 lenovo

I made a dynamic component in which one I want to authorize some sizes to be choosen from a list. My component works, even if it’s not perfect, can change value in attribut but option windows doesn’t work as it’s supposed to be.
First I remove the DC plugin to be sure to have the last one. Then ater rebooting, I got the first parameter I want to change in the option window. Then I said to myself WIN ! I can add some more. I tried a second, same way, save the component and open the option window with the toolbar. There what a disapointing situation. Only the first parameter shows up. Second ? nada !
I remove again and re-install the DC puglin. Same result, only the first one is there.

I applied what you said above desactivation/ DCtollbar removing/ restart/ re-activation of the plugin/ component reload and use only the right click to access DC menu. Same issue. I am more than frustrated!

Any idea ?

Nicolas
PS : hope you understand my French-English…

Nicolas…you might consider posting the .skp file here so the experts can look at it. I don’t consider myself that person, but there are some very generous expert type people here who will take a look.

Also, I would highly recommend starting your own thread on this question. It will get more focused attention.

1 Like

Hello,

Sorry for replying so late, but I finaly found out where the problem comes from : option for the parameter I would like to easily modify was not set-up at top level of the DC. Just move it up and so works !!

Anyway thanks for your help and next time I will open new post and attach my DC.

Regards,
Nicolas