Dynamic Component option fail

Hi,

I have been using Flex tools which is a great tool but have had issues for a while and thought it was flex tools DC objects, but manged with work arounds as was to busy to look into the issue.

No that I have looked into it further it would appear that it is DC objects in general.

When I want to edit the DC options ether by clinking on the icon on the tool bar or by right clicking and selecting DC - component options i get the following

Has anyone else had this or know what I can do to remedy it?

Thanks in advance.

What is the name of the SketchUp file?

its in any skp file that I try to use DC options in.

Has know one else had this issue or similar?
It is super frustrating as it makes all DC unusable.

Any help would be appreciated.

Hi Sam,

  1. I’ve seen this error come up before when the Windows user name had an apostrophe " ’ " in it, though if you have FlexTools installed, we have patched the Dynamic Components bug that causes this error (in May 2020), so as long as FlexTools is installed the bug shouldn’t appear. Please make sure you have updated to the latest FlexTools.

  2. Are there any ‘non-standard’ characters in your Windows user name?

  3. Please see if any of the suggestions here help: FAQ – FlexTools

HI Frandzel,

Thanks for your comments.
I have the most up to date FlexTools.
I have checked what you have mentioned above, the user name is fine.
I have also gone though the FAQ link, I do have a /O in the file location (…ve\OneDrive\Clients\W\Walter - Mark & Jean\Drawings\Sketch\3D) so made a copy in a different location with none of the issue letters and still no luck.

Can you please send all of your FlexTools log files to: https://flextools.cc/contact

You can find them at:
C:\Users\%USERNAME%\AppData\Local\F3d_FlexTools\logs

HI,

Thanks, I am trying to but attach the log files but cant as it says “opps. this file type isn’t allowed”

Try to zip the log files and see if that works

Thanks that worked.
As you can properly tell I’m not very computer savvy outside of sketchup.

You sure you sent the files? :slight_smile: Nothing has arrived here yet.

sorry didnt send for some reason
has sent now

Hi Yoni,

I’m just chasing this as I have not heard anything.

I had not replied to your last email as I received an automated reply from FlexTools saying that my data had been received.

Please let me know if you need anything else.

Regards,
Sam

Hi Sam,

Thanks, we received the files and I’ve replied to your email. We tried to recreate the issue by creating a new windows username similar to yours, but that did not seem to reproduce the error.

I sent you a few more things to try (like disabling all extensions except for the DC extension…)

I just got your email that disabling all plugins and then re-enabling them 1 at a time seems to have solved the issue! Great!

Thanks for your help on this frandzel3d i’m glad that I can now us DC again.

1 Like