Dynamic Components - Call back error "dcbridge"

dynamiccomponents

#1

Dear Sirs,

I am posting this issue as a new topic as it seems related topics are closed.
In my opinion, Dynamic Components (DC), are very important to the future development of Sketchup.

Without them, (or something better), Sketchup cannot be part of BIM & we will have to model every instance of a Component, (i.e. many doors of all sizes)!

This item needs urgent attention, as DCs are still very sensitive.

Over time, I have developed a door DC (Door2018_DC.skp …
DC_Door_2018.skp (277.2 KB) ), enclosed and available on 3D warehouse.

In using the above DC, I have encountered some issues with Dynamic Components and my existing ".skp" template files, which display the famous "dcbrige" notice.

I have run and repaired the sketchup program as "administrator" & have the latest version of DC 1.5 installed.

Issue - 1

When I insert the enclosed Door2018_DC.skp (old_template.skp (823.0 KB)
) in the enclosed template file “old_template.skp” & immediately open the “Component options” or the “Component attributes” dialogues I get the famous “Dcbrige” notice.

But if I save the file and reopen it, then I get:

Issue - 2

In either the referred re-saved "old_template.skp" or the enclosed "door_NewTemplate.skp" … Sketchup is sensitive to the order in which the "Component options" or the "Component attributes" dialogues are evoked, (i.e. pressing the icon buttons).

To see what I mean please follow the steps below within the "door_NewTemplate.skp":

Open “door_NewTemplate.skp” & (door_NewTemplate.skp (308.3 KB)
) step:

1 - click on the door DC;

2 - then click on the " Component options" and it will populate as expected;

3 - then click on the " Component attributes" and it will populate as expected.

However, if you alter the order … i.e with no DC selected:

2 - click on the " Component options" icon … and it will be blank, as expected;

3 - then click on the " Component attributes" icon, and it will be blank, as expected

1 - and only then click on the door DC:

the " Component options" will not populate as expected … remains blank (!?);

but the " Component attributes" … will populate as expected (?)

Only after closing and reopening will "Component options" & "Component attributes" redisplay as expected & if the above order is followed.

On the forum, I have also read that the “u” character was causing problems, I have checked and don’t think it applies to this case. However, some of my DCs have the “#” character prefix … will this cause problems?

Appreciate any advice or help to resolve this matter.


#2

Seems the Component Name “ArchtvWR” was used TWICE. Please take a look at the Bottom Compo on the Compo-Attribs List. Perhaps this last one needs to be RENAMED to “ArchtvWL”.

I’d also recommend not using Blank Spaces when Naming DC Compos in the Attributes Window.

In addition; some of the Parent - Call Back formulas have to be Refreshed. That’s may be done by Re-Typing the formulas.


#3

The (not) populating of the dialog boxes via the toolbaricons has been reported earlier. In windows you would only need to start SketchUp again, on Mac you would have to disable and enable DC in the extension manager.

I only use rightclick on the component to open the dialogs.


#4

Thank you … I’m looking too long at the screen and missing the details !

Below is the update.

DC_Door_2018.skp (268.2 KB)


#5

Thank you for the good tip … disabled the DC toolbar … and will now work … “Blender style - right clicking” :wink:

S.