No activation email... again

Hi, looks like I also have the activation email problem with trying to set up a trimble account.

Using Sketchup Make, and it looks like I cannot use my google account to download from the 3DWarehouse anymore.

I have sent a support request, but as yet no response.

Setting up an account with this community also didn’t produce an activation email until about 3 days later, and it was a “reminder to confirm” email rather than the original that came through.

Looking through this forum, it looks like this isn’t the first time, and yes, I have a hotmail email address.

Is there a domain I should be whitelisting to allow the emails to come through?

You could use your google account, but you would have to create a new password.
Open an incognito tab in your browser, try to sign in at,but don’t use the Google log-in-button, just type the google-emailaddress in the top field. Then start the procedure to create.

An email from would probably end up in the spamfolder

Your attempt to use your new Trimble ID has locked you out, I think perhaps that you were entering your regular Google password, and not the one for Trimble.

I just had a password reset email sent, and as you are using Hotmail it is very likely to go into the Junk mailbox. Most Microsoft email systems do that. They do it in a way that doing a search for something won’t show any results, but browsing to the mailbox itself does work.

So, don’t search, just browse into your Junk mailbox. Look for a message from Trimble that came in a moment ago. You may find older emails there as well, but start with the password reset email, and get a password going, and make a note of it, to use next time you’re signing in from within SketchUp Make.

Unfortunately, Trimble’s password rules are tougher than most, which often means you can’t use the simpler password that you’ve used with Google or Microsoft.

Thanks for the ideas, here is a bit more info:

  • I have checked Junk numerous times over the past week, still no emails received
  • I have tried the reset password link numerous times, still no emails received

It looks like I can still download models straight from the 3DWarehouse site using my Google account, so for now I can keep working around the issue. It’s just a pity that I can’t use it straight from within Sketchup itself.

For giggles I will try to whitelist the domain for my hotmail account and see if that makes it work.

Well… bit of a weird update…

I tried the reset password again after adding to the safe senders list with my hotmail account, but still no luck getting an email.

In other news, it looks like browsing the 3D warehouse from within Sketchup has allowed me to use the Google account login process again. Not sure when that option was added back in…

If you’re still using any version earlier than 2019.3, you can’t sign in with Google from within SketchUp. But, you can browse 3D Warehouse without signing in. For a while I think you had to sign in to even browse, but that seems to not be true at the moment.

I do see your email active now as a Trimble ID, perhaps you got through the password issues in some other way.