Can't log into Trimble Account?

I can’t sign into my Trimble account. When I try to lo my account using my gmail.com account I get this message

Google couldn’t verify this account belongs to you.

Try again later or go to https://g.co/recover for help.

I’ve done this, nothing. I’ve sign up for a Trimble connect account, still nothing. I’ve tried to download Trimble connect 2.0 via sketchup extensions, It won’t load.

Any help please?

You can bypass the google login and start the ‘forget password’ procedure.
Check here:

https://help.sketchup.com/en/trimble-identity-frequently-asked-questions

Thanks for the reply, but it’s no use. I went through the steps and got this

Thanks for confirming that you can access the contact email address you provided.

Unfortunately Google couldn’t verify that ‘myaccountname’@gmail.com belongs to you.

From the message you got, this sounds like a Google problem. Maybe you need to check with Google to see if there’s an issue with your e-mail address or login.

What did you buy? Were did you bought it?
Contact them to assign it to an emailaddress were you have access to.

I’ve been through the email recovery process, and still nothing.

I haven’t purchased anything.

I use the free version of Sketchup, and when I went to upload a model last week, I got the message. I’ve looked at other threads online, but as yet … nothing, i’m still locked out!!

Which free version? Your profile is confusing because it indicates a version that doesn’t exist.
Screenshot%20-%207_10_2019%20%2C%2011_39_01%20AM

If you are using the web-based version as you seem to indicate in your profile, extensions can’t be installed.

Please correct your profile with the right information so we can give you some additional guidance without having to guess.

1 Like

I’m not very technical (hence that’s why I’m here I guess). I don’t have any further information other than I’m using … what looks to be … Sketchup Make 2017.

You could try uploading a acreenshot of what you are seeing (first, make as screenshot of your screen when you have SketchUp open, then reply on this thread and drag the screenshot in the message)

Perhaps you could update your profile so at least it is correct.

Done.

Have you tried closing SketchUp, clearing Chrome caches and then logging in again?

When you installed SketchUp, did you right click on the downloaded installer file and select Run as administrator from the Context menu? If not or if you don’t know, it would be a good idea to do that and when presented with options, select Repair.

Have you tried closing SketchUp, clearing Chrome caches and then logging in again? - Yes!

When you installed SketchUp, did you right click on the downloaded installer file and select Run as administrator from the Context menu?

I t was a few years ago, but I assume the former.

To make sure SketchUp is installed correctly if would be worth repairing the installation. Find the installer file or download a fresh copy of it, right click on it and choose Run as administrator. When presented with the options, choose Repair. Make sure you have closed SketchUp before doing this.

Did that, nothing!

I’m wondering if it would just be easier to set up a different gmail account?

Maybe it would.

Thanks for all the help DaveR … and to everyone else. :grinning:

You’re welcome. Does that mean you have it sorted out?