Newly installed latest SU v23 repeatedly crashes on opening on Mac and choosing a recent file

I’ve just installed the latest SU v23 for Mac, running on Monterey v12.6.6.

Created an alias, and dragged it into the dock.

Whenever I try to start SU from the dock alias, it presents a window with recent files, but crashes when I try to open any of them.

Doesn’t crash if I choose to open from a template file in the same window.

It opens normally from Applications/Sketchup 2023/, and also opens without crashing if I double click on a SU .skp file.

What am I doing wrong?

Should I just have opened it from the Applications, then selected Options/Keep in dock?

PS. I deleted the entire previous Sketchup 2023 folder before reinstalling the latest version.

PPS. It’s now crashing immediately if I try to open any existing file from the Recent files window it opens to show, even if I start it by double clicking on Applications/Sketchup2023/

But it will open a template file without crashing, and the File/Open menu from there will open any of the existing Recent files.

The previous version of SU 2023 was working fine.


Thanks for that, Steve (@slbaumgartner).

It’s getting very late here, so I’ll try reverting to the previous version (if I can find the installer) tomorrow.

I’ve found a 2023-0-418-179 installer. That also seems to be the one on the Download All | SketchUp

rookie mistake, never install an update between friday and monday morning. it’s cursed :slight_smile:

SU is not asking me to update yet, so I’ll wait. thanks for the warning.
I wonder if it’s a SU crash or a Monterey crash. Between monterrey and Ventura they changed several security things to “protect” the users, and what you describe feels like a “you don’t have the right to access this thing” bug.

yeah looks like an issue with the access rights to the previous files list and the dock icon. Could it be that it was the dock icon from the previous version, and now when launching from it, it opens the new version but with glitches ?

Pinging @colin , He’ll see this on monday (or before if he takes a break from his weekend to do some forum stuff) and transmit to the devs.

When you say it crashes, do you get any bugsplats ? did you send any ? (so colin can see the mechanics of the crash)

Yes, bugsplat every time. I sent them in, giving my email address, and sometimes noting that it was on startup.


Again, weekend and all, we won’t hear news until monday, but hopefully Colin can identify the problem from the bugsplats.

I edited a couple of the posts, because the version you gave must have been wrong in some way.

The crashing when choosing recent files is a new variation. When I was seeing a similar crash, opening from the recent menu still worked.

One thing to check, see if any of the recent files are ones that are in an iCloud folder, and maybe right now is not synched locally.

I will be looking at what differences there are in the crashes me, you, and Steve are seeing, to hopefully find out what they have in common. I am not sure how much of that I will do before Monday!

1 Like

Thanks, Colin.

No panic - I’ll revert to an earlier version in the meantime.

All of the recent models I tried to open are on my local hard disk in a folder which is not synched to any cloud service.