Bug Splat when files are opened on startup

When I attempt to open a file from SU it crashes. When I open it from from it’s folder it opens. This happened last time a new version was installed and I can’t remember what the fix was. Any suggestions would be appreciated.

We have seen some crashes recently that would go away if the preferences file was regenerated. Doing that would mean losing some of your toolbar layout, but that’s better than having crashes all the time.

Close SketchUp if it’s open, then in File Explorer, paste in this path:

%LocalAppData%\SketchUp\SketchUp 2024\SketchUp\

Rename the file PrivatePreferences.json to something else, and open SketchUp again. See if the crashing still happens.

If that hasn’t helped you could go back and delete the newly created PrivatePreferences.json file, and rename the old one back to PrivatePreferences.json, and get your toolbar layout back.

Thanks so much. That is what I ended up doing last time as I recall

Dave,
The current open file also crashes when I close it however it saves the file.

Colin,
I renamed the file as suggested. Nothing has changed. I do recall one or two versions ago when I did a similar exercise and it did work. This appears to have something to do with where I save my drawings and my setup in preferences. If you have any other suggestions I would be a willing test rat.
Thanks,
Barry

After renaming the file, and starting SketchUp again, did you have to agree to the terms and conditions? If you didn’t, the renaming wasn’t on the right file. If you did, then I’m not sure what is wrong.

1 Like

When I rename the file (I have rename it several times with different names) and then attempt to launch SU it repopulates the file with the correct name in that same folder. I have 3 screens and I watched it happen in File Explorer. I am then asked to accept the preferences. When I select start modeling, the program crashes. Does that provoke any thoughts?

Next thing to try would be starting with the basic plugins. You could rename the Plugins folder at %AppData%\SketchUp\SketchUp 2024\SketchUp\ so that SketchUp starts up with only the shipped extensions.

1 Like

OK I think I did read somewhere there were issues with Fredo LibFredo6. I will try disabling some extensions. At this point when SU launches I have to set up the trays and extensions every time it opens.

You might try updating LibFredo6 to the current version (v14.4c) via the Sketchucation ExtensionStore. Make sure it’s also up to date (v4.4.1).

I haven’t had any Bug Splats related to LibFredo6.