SU2017 Crashing when opening via file


#1

Hi All
Looking for some advice on how to stop SU2017 Pro from crashing every time I click on a file to open, or try to use the recent file list on the taskbar. Everything seems fine if I open with a new file and then open any other file once SU is running.


#2

Are you trying to open files stored in a “cloud” like Dropbox? Have you installed plugins?

Anssi


#3

Hi, thanks for the reply.

Files are all stored locally, have a couple of plugins as per screenshot below.

with your suggestion, I disabled all plugins and it all worked perfectly. I then started to switch them back on one at a time and after I re-enabled dynamic components plugin, SU will not start at all now, Bugsplat every time even when opening normally (ie, not via clicking on file)

so I guess it seems to be plugin related?


#4

Ok, to update, I have been able to start SU again and switch off the dynamic component plugin, but didn’t solve the problem, only made it intermittent. I then switched off all plugins again and it still seems to be an intermittent issue.


#5

When SU crashes, are you getting BugSplat? If so, you should be submitting them with info identifying you and linking to this topic so that the Trimble staff can investigate the crash and report their findings. An intermittent problem suggests that there is something else happening on your computer and the crash occurs only when the timing aligns. These are the hardest kind of problems to track down!


#6

And of course, do you have the latest GeForce graphics driver from Nvidia ?


#7

Are you running the latest maintenance release of Sketchup 2017? At some point there also circulated a buggy version of the Dynamic Components plugin - you could check if your version is one that has an update.

Anssi


#8

Thanks all for your help, I seem to have fixed the issue.

Seems to have been two issues, One with Graphics Card and one with Dynamic component plugin.

After having turned of the graphic card within SketchUp and then restarting SU and turning it back on things got a lot better. then found I was also having issues with dynamic components doing strange things, I then uninstalled and reinstalled the DC plugin. I did have the latest version, but re-installation seems to have worked.

SketchUp now seems to start as expected and DC’s are working properly.

So once again thanks for the advice, much appreciated.