Newbie - getting an error message and will not even install


#1

The following error message appears and the install stops and cancels:

Could not open key:
HKEY_CURRENT_USER\Software\Microsoft\Internet
Exprlorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION.
Verify that you have sufficient access to that key, or
contact your support personnel.

First time trying this and attempting to install on my personal laptop. Signed in as administrator. NOT sketchup Pro, just the normal free version.

Windows 7 and using Firefox.

Not a power user but can follow instructions.

Please help.


#2

That’s a step in the right direction.
Then, try a right click on the WIN SketchUp 2015.exe installer > Run as Administrator.

Does that help?


#3

Have tried that a few times and it did not make the least bit of difference


#4

Two questions,
is the spelling error of Explorer your typo or was that the real message?
do you have Internet Explorer on your laptop and is it up to date?

Using Firefox is irrelevant in this case as Sketchup always uses Internet Explorer on windows and Safari on Mac.


#5

sorry for the delay… my typo.

Also performed every Microsoft update available, including IE11, so nothing left to update.

Still getting the same error.


#6

This is blowing my mind.

right clicking to install as administrator. All the updates are done. No idea what the problem is.


#7

even tried getting hold of technical support but they refuse to help unless I buy the Pro version, which I most definitely will not if I can’t get this to install and check it out.


#8

Have you tried a Registry cleaner/repair utility?


#9

Hi @christiaanbarnard777,

If there’s an issue with the installer, there’s a utility from Microsoft that could do the trick:

http://support.microsoft.com/mats/program_install_and_uninstall


#10

I have the exact same problem, just downloaded SketchUpMake-en-x64. I’ve updated and run the installer as admin. I have Windows 8.1 64 and have tried the above microsoft tool and still no luck.


#11

Hi @nickjbyrne

Would you mind uploading a screenshot of the error message?

Many thanks, good sir.


#12

Hello Nick,

Please see SketchUp Make 2015 (64-bit) fails to install

Regards,
Yogesh


#13

Here you go


Sketchup 2017 Installation fails Win8.1 [could not open key - SOLVED]
#14

Hi Yogesh, I followed the advice in the ms link and checked to make sure i had the update KB2918614 installed and i do. The full message from application log is

Product: SketchUp 2015 -- Error 1402. Could not open key: HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION.  System error 5.  Verify that you have sufficient access to that key, or contact your support personnel. 

After googling around a bit, i opened regedit and navigated to the key, i couldnt open it (or even open featurecontrol key) however if i used C:\Windows\SysWOW64\regedit.exe i could navigate all the way to that key.


#15

Interesting. Do you get the same error when you try to install the 32-bit version of SketchUp Make 2015?


#16

Thanks, the 32-bit version installs with no problems, I’ll use that, shame i can’t use the 64-bit version, is this something specific to my installation of Win8.1 64 or a general problem? My version is preinstalled by Lenovo on my all-in-one system.


#17

I couldn’t be bothered in trying to install this anymore as no version wants to work. Downloaded autocad for free with a free 3 year licence from their website. No problems.


#18

[ @andrew - Would you mind reviewing this thread and add your thoughts on this issue? ]

Hi @nickjbyrne – I’m glad to hear that the 32-bit version seems to be a viable work around to this issue.

hi @christiaanbarnard777 – I’m so sorry to hear that SketchUp couldn’t seem to find a way to install on your computer - the 32-bit version or the 64-bit version. I invite you to keep an eye on this thread as new updates come along.


#19

Hi every one
Im having the same problem now. I cant install the sketchup make version
any idea to fix it?


#20

Hi @yanzarchi. Would you mind sharing any error messages you see or more information that indicates how SketchUp Make is having troubles installing on your computer?

Many thanks.