Why won't SketchUp Install?

I have tried Installing SketchUp 3 times now, and I keep getting the same message
"HKEY_CURRENT_USER\Software\Microsoft\InternetExplorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION"
How can I fix this?

Right-click the installer exe, and choose “Run as administrator”.

After install, right click the icon, choose “Properties”, switch to the “Compatibility” tab, and at the botton, check the box for “Run as administrator”.

Thank You for the response but I have tried that numerous times and it still wont install and I get the same message. I right click the installer.exe, choose run as Administrator, and nothing changes.Thank you,Anthony

After reading the earlier responses, I would suggest that you find a way to defrag the disk drive, clean out your computer with a good utility (I use CCleaner from Piriform), then hard boot your computer. Last, verify that you have the latest Internet Explorer version.

I searched for you the quoted message above and saw a few results that may also interest you about “… browser emulation…” settings.

Good luck.

In your TEMP directory, delete the “sketchup_install” folder if it exists, before any re-attempts at running the installer. (If any errors occur, this folder may have files left behind, and it has been reported that the folder or left over files cause the installer to “error out” afterward. I personally have never had this issue, and the folder is always there on my machine with some version of the “setup.exe” and the “SketchUp201n-x64.msi” files in it.)

This is a registry key path, into which the SketchUp installer will write (or change) the “sketchup.exe” attribute.

Although the key path is complete (and correct) it is not a complete error message. Does the error message say what the issue is, involving this registry key ?

Right now we can only guess that the installer is having trouble setting the attribute. Sounds like a permissions issue.

  • Try to temporarily switch off any firewall or security software that may be trying to (over zelously) protect the registry from changes.

  • Try installing after logging onto your system as the administrative account. (Not your normal account.)
    How to Geek: Enable the hidden administrator account on windows

  • Try running the install in Windows Safe mode ?

Thanks a million for your advice. I figured it out. I opened the REGEDIT program on my computer and had to change the permissions to access the FEATURE_BROWSER_EMULATION. Once I was able to access it, I deleted it totally. After that SketchUp installed fine. Thank You again for your input, it’s good to know that if I ever have a problem I can come here.
Anthony

1 Like